Page MenuHomePhabricator

Cannot create new global groups with XCache or CACHE_ACCEL
Closed, InvalidPublic

Description

Author: eveah.bot

Description:
I cannot create or edit global groups. I did run migrateStewards.php, and also added the appropriate permissions (globalgrouppermissions and globalgroupmanagement). Even after doing those things, I still cannot create new global groups or edit existing global groups.


Version: unspecified
Severity: major

Details

Reference
bz28095

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 11:36 PM
bzimport set Reference to bz28095.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Mar 17 2011, 3:45 PM

eveah.bot wrote:

After talking to Brion, and getting a stroke of inspiration, we determined the issue is with caching. If XCache or CACHE_ACCEL is set, the cache may not clear properly, keeping old permissions even through log out/log in. Changing the cache type to CACHE_NONE has solved the problem.

Legoktm closed this task as Invalid.Jan 7 2016, 8:44 PM
Legoktm claimed this task.
Legoktm added a subscriber: Legoktm.

Because APC is not shared from the CLI to the web server, the cache purge from a maintenance script doesn't work. I would recommend triggering cache invalidation from the web by doing something on the wiki or restarting your webserver.