Provide a real-time collaborative editing system
OpenPublic

Assigned To
None
Priority
Normal
Author
bzimport
Commits
Unknown Object (Commit)
Subscribers
Aklapper, Jdforrester-WMF, MarkAHershberger and 3 others
Projects
Reference
bz1898
Description

Author: regress

Description:

WikiMeet - Real-Time Concurrent Editing

WikiMeet is a blend of the Wiki philosophy with the productivity potential of
[http://en.wikipedia.org/wiki/MoonEdit MoonEdit] and the grace of
[http://en.wikipedia.org/wiki/SubEthaEdit SubEthaEdit].

Being able to see the changes that are happenning in real-time in a rich-text
editor would push the wiki philosophy in a new direction. While admittedly, it
would often be distracting for large-scale sites with many users editing at
once, it is ideal for many situations.

Examples:
*A blending between chatting and wiking. Rather than discussing changes in one
window and then implementing them in another, it would be a huge time saver to
both discuss and implement the changes ont he wikipage itself.
*Coding together through this system would in many cases provide a huge boost in
productivity.
*Collaborative writing - In terms of writing books or papers, being able to see
these changes in real time is crucial.
*Online collaborative-notes for classes. As the instructor is lecturing, the
students can create and organize their notes, see the changes and notes the
other students are creating, etc. At the end of the class, the result should be
an impressive document covering all the relevant material discussed in that session.

Real-time is the key here. Possible implementation methods include an ajax
front-end with a java backend, active-x (yech), flash, or some other as yet
unnamed method.

It should be built as an extension to the current mediawiki project, as an
optional method for editing the text, ie.

Edit:
*View other's edits in real-time
*Edit alone

So we don't alienate people who feel uncomfortable or annoyed with this
methodology, yet allow those who would take advantage of the feature to do so
without jumping through additional hoops.


Version: unspecified
Severity: enhancement
URL: http://intcomm.wiki.taoriver.net/moin.cgi/RealTimeCooperativeEditingSystemsPaper

bzimport set Reference to bz1898.
bzimport created this task.Via LegacyApr 15 2005, 3:40 PM
bzimport added a comment.Via ConduitAug 6 2005, 2:09 AM

ui2t5v002 wrote:

"Rather than discussing changes in one window and then implementing them in another"

There would then be no record of the discussion?

bzimport added a comment.Via ConduitApr 28 2006, 4:19 AM

Wiki.Melancholie wrote:

It's not exactly what you want, but on [[fr:]] they use a JavaScript tool that lets you
previsualise your changes pretty fast and easily, without having to submit the changes to the
servers first (preview button). But it does not work in real-time, so this is just a minor note.

mxn added a comment.Via ConduitApr 28 2006, 6:12 AM

As a first step, it would at least be nice for the edit page, after (say) 15
minutes, to check with the server and see if the page has already been edited.
If it has been edited, the page could then automatically display a note and
diff, so that the user will know beforehand about the edit conflict and not make
things worse by continuing to make changes. The ping interval should be long
(and probably configurable), so that the server doesn't get bogged down by a
bunch of users who forgot they had that other window open. :)

Bawolff added a comment.Via ConduitMay 15 2011, 6:34 PM

(In reply to comment #4)

http://hackpad.posterous.com/live-editing-mediawiki-with-hackpad looks fixed
for me

Have you tried it? Well its a step in the right direction, I wouldn't exactly call it usable by the general public [or perhaps it just sucks on my browser]. But really this is a dupe of bug 4427

MZMcBride added a comment.Via ConduitMay 17 2011, 5:18 AM

This isn't fixed in any real sense. Re-opening.

(In reply to comment #5)

Have you tried it? Well its a step in the right direction, I wouldn't exactly
call it usable by the general public [or perhaps it just sucks on my browser].
But really this is a dupe of bug 4427

That bug would be a duplicate of this one, if anything. This bug came first.

Bawolff added a comment.Via ConduitMay 17 2011, 5:21 AM
  • Bug 4427 has been marked as a duplicate of this bug. ***
Jdforrester-WMF added a comment.Via ConduitJul 4 2014, 12:37 AM

Renaming so people find it.

epriestley closed this task as "Resolved" by committing Unknown Object (Commit).Via DaemonsWed, Mar 4, 8:24 AM
Aklapper reopened this task as "Open".Via WebWed, Mar 4, 8:50 AM
Aklapper added a subscriber: Aklapper.

Accidental clash. Known issue. Reopening; Sorry for the noise.

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.