Page MenuHomePhabricator

Rename "chapcomwiki" to "affcomwiki"
Closed, ResolvedPublic

Description

Following a Board of Trustees resolution[1] and a discussion between the Committee's members during its meeting in Berlin to change the name of the Committee, I would like to ask to rename its internal wiki (http://chapcom.wikimedia.org) from "chapcomwiki" to "affcomwiki" (http://affcom.wikimedia.org).

I know that it's rather difficult to rename wikis at the moment, and that this might take some time, so I am filling the bug even before the formal change of the name (which would be done through another Board resolution).

And, of course, this is merely a technical request, as there is consensus among the ChapCom/AffCom members to move the wiki to the new name.

References

Thanks in advance,

  • Tomasz (odder)

Version: unspecified
Severity: normal

Details

Reference
bz39482

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 12:58 AM
bzimport set Reference to bz39482.
bzimport added a subscriber: Unknown Object (MLST).
tomasz created this task.Aug 19 2012, 1:02 PM

Adding 'shellpolicy'.

Please tell us informed when you've the consensus.

tomasz added a comment.Sep 7 2012, 2:30 PM

Sorry? There is no need for a consensus here, the Committee's wiki is a private one, limited only to its members and advisers.

We woud like to have the name of the wiki changed following the change of the name of the Committee - see http://wikimediafoundation.org/wiki/Resolution:Affiliations_Committee_Charter for more information.

(In reply to comment #1)

Adding 'shellpolicy'.
Please tell us informed when you've the consensus.

Errrr, no, reverted. If odder says he speaks for the committee then he speaks for the committee.

Oh sorry Odder, I misread the following paragraph ("there isn't " instead "there is"):

And, of course, this is merely a technical request, as there is consensus among
the ChapCom/AffCom members to move the wiki to the new name.

Thank you for the precision.

MediaWiki config: https://gerrit.wikimedia.org/r/53892

Apache config: https://gerrit.wikimedia.org/r/53894

Daniel is making the DNS changes

This needs scheduling due to the database rename that is needed

added to DNS:

;; QUESTION SECTION:
;affcom.wikimedia.org. IN ANY

;; ANSWER SECTION:
affcom.wikimedia.org. 3600 IN CNAME wikimedia-lb.wikimedia.org.
wikimedia-lb.wikimedia.org. 600 IN CNAME wikimedia-lb.eqiad.wikimedia.org.
wikimedia-lb.eqiad.wikimedia.org. 3600 IN AAAA 2620:0:861:ed1a::
wikimedia-lb.eqiad.wikimedia.org. 3600 IN A 208.80.154.224

Reedy added a comment.Mar 15 2013, 2:22 AM

(In reply to comment #5)

MediaWiki config: https://gerrit.wikimedia.org/r/53892
Apache config: https://gerrit.wikimedia.org/r/53894

Deployment attempted and reverted due to issues renaming external storage tables

Change 53921 abandoned by Hashar:
Bug 39482 - Rename "chapcomwiki" to "affcomwiki"

Reason:
Old rotting patch. Feel free to restore if that is still needed.

https://gerrit.wikimedia.org/r/53921

Hello

I 'm intrested in working on this bug,Can anybody please assign it to me..

(In reply to comment #9)

I 'm intrested in working on this bug,Can anybody please assign it to me..

Not really; the bug has the 'ops' keyword which effectively means that only employees of the Wikimedia Foundation Operations Team are capable of resolving it (since it requires direct access to one or more servers or closed repos to change DNS settings, etc.). Thanks for asking, though :-)

(In reply to comment #10)

the bug has the 'ops' keyword which effectively means that only
employees of the Wikimedia Foundation Operations Team are capable

Correct that this issue isn't fixable without specific permissions.
I'd just like to mention that many (not all) ops tasks can also be at least prepared (patches) by volunteers (e.g. Apache config changes). :)

(In reply to comment #11)

I'd just like to mention that many (not all) ops tasks can also be at least
prepared (patches) by volunteers (e.g. Apache config changes). :)

Also, one example from comment #10 is wrong:

DNS can now be patched by any volunteer just like apache config.

https://git.wikimedia.org/summary/?r=operations/dns.git

  • Bug 69670 has been marked as a duplicate of this bug. ***

Change 169944 had a related patch set uploaded by Reedy:
chapcomwiki -> affcomwiki

https://gerrit.wikimedia.org/r/169944

mediawiki config side of this for Mutliversion is at https://gerrit.wikimedia.org/r/#/c/169939/

what's the status on this rename? looks like the related patches are merged but http://affcom.wikimedia.org/ has a splash page and https://chapcom.wikimedia.org works

Dzahn added a comment.Mar 31 2015, 4:23 PM

Wiki renaming is probably still blocked by external storage. Last time i heard about it it was about renaming databases on ES and Asher (dba before springle) said it requires some scripting on that side.

@Springle we were wondering about external storage and wiki renaming (chapcom -> affcom in this case), ideas?

fgiunchedi lowered the priority of this task from Normal to Low.Apr 2 2015, 11:37 AM
Dzahn changed the task status from Open to Stalled.May 7 2015, 12:20 AM
Dzahn added a comment.Jul 14 2015, 5:50 PM

What about the pending Apache config change to redirect it? Is it moot until we figured out the issues with ES?

https://gerrit.wikimedia.org/r/#/c/169944/

task is from 2012, DNS was added in 2013

Restricted Application added a subscriber: Matanya. · View Herald TranscriptJul 14 2015, 5:50 PM

What about the pending Apache config change to redirect it? Is it moot until we figured out the issues with ES?
https://gerrit.wikimedia.org/r/#/c/169944/

Does MediaWiki/MultiVersion know that affcomwiki exists? If it doesn't, I don't think it would properly work. In the meantime, I think it would be worthwhile to either set up a redirect from affcom.wikimedia.org -> chapcom.wikimedia.org or set it as a server alias?

it's not yet in wikiversions.json so I guess the answer to the previous question is "no".

Change 233972 had a related patch set uploaded (by Alex Monk):
Add affcom wiki domain to apache config

https://gerrit.wikimedia.org/r/233972

Change 233972 merged by Giuseppe Lavagetto:
Add affcom wiki domain to apache config

https://gerrit.wikimedia.org/r/233972

Change 234320 had a related patch set uploaded (by Alex Monk):
Move chapcom.wikimedia.org to affcom.wikimedia.org

https://gerrit.wikimedia.org/r/234320

Change 234320 merged by jenkins-bot:
Move chapcom.wikimedia.org to affcom.wikimedia.org

https://gerrit.wikimedia.org/r/234320

Krenair changed the task status from Stalled to Open.Aug 27 2015, 5:22 PM
Krenair claimed this task.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 27 2015, 5:22 PM

https://affcom.wikimedia.org/wiki/Main_Page works, other pages should too.
I guess we should add a redirect for chapcom -> affcom next, and remove the dual-host Apache config.
After that the only thing not done is your Project namespace which is called 'Chapcom' still. I think that can be renamed and an alias put in place for the old name if you like. @Varnent?

Change 234404 had a related patch set uploaded (by Alex Monk):
Redirect chapcom.wikimedia.org to affcom.wikimedia.org

https://gerrit.wikimedia.org/r/234404

Keegan added a subscriber: Keegan.Aug 27 2015, 7:46 PM

Oh and, I guess you'll want the favicon changed too?

Varnent added a comment.EditedAug 28 2015, 8:38 PM

Yay! *happy dance* Thank you!

Macro tech-barnstar:

Yes - an update to project namespace and favicon change would be wonderful. :)

<snip>

<meme>

<snip>

Oh my.

I admit - I am not yet sure how I feel about these memes..but...felt it was worth it here. ;)

The first two I tried were....more alarming... (why are they so large!)

Krenair added a comment.EditedAug 28 2015, 10:26 PM

Yes - an update to project namespace and favicon change would be wonderful. :)

Would you like to provide a new favicon .ico file? You can find the existing one at https://phabricator.wikimedia.org/diffusion/OMWC/browse/master/w/static/favicon/chapcom.ico :)

Change 234679 had a related patch set uploaded (by Alex Monk):
Update project namespace name and favicon on affcom.wikimedia.org

https://gerrit.wikimedia.org/r/234679

Going with the WMF icon logo seems the most logical and easiest IMHO.

https://commons.wikimedia.org/wiki/File:Wikimedia-logo.svg

Great, we already have that in the repository.

Change 234679 merged by jenkins-bot:
Update project namespace name and favicon on affcom.wikimedia.org

https://gerrit.wikimedia.org/r/234679

Krenair closed this task as Resolved.Aug 28 2015, 11:46 PM
Reedy added a subscriber: Reedy.Aug 29 2015, 9:28 AM

Change 233972 had a related patch set uploaded (by Alex Monk):
Add affcom wiki domain to apache config
https://gerrit.wikimedia.org/r/233972

Change 234404 had a related patch set uploaded (by Alex Monk):
Redirect chapcom.wikimedia.org to affcom.wikimedia.org
https://gerrit.wikimedia.org/r/234404

I had already done most of that in https://gerrit.wikimedia.org/r/#/c/169944/ (just abandoned) :P

Change 234404 merged by RobH:
Redirect chapcom.wikimedia.org to affcom.wikimedia.org

https://gerrit.wikimedia.org/r/234404

Krenair moved this task from Backlog to Done on the Wikimedia-Site-requests board.