Page MenuHomePhabricator

GettingStarted extension broken at beta.wmflabs.org
Closed, DeclinedPublic

Description

to reproduce:

  • go to random page
  • append ?tour=gettingstarted to the page URL
  • "Ready to help" guider should appear
  • click Next
  • "Click Edit" guider should appear
  • click the Edit link on the wiki page
  • Preview guider should appear, but it does not appear

Version: unspecified
Severity: normal

Details

Reference
bz51362

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 1:57 AM
bzimport set Reference to bz51362.
bzimport added a subscriber: Unknown Object (MLST).

Related to bug 47194.

The same problem at en.wikipedia.beta.wmflabs.org

greg moved this task from To Triage to Backlog on the Beta-Cluster-Infrastructure board.
greg added a subscriber: greg.
faidon removed a subscriber: faidon.Nov 25 2014, 1:03 AM
greg moved this task from Backlog to tmp on the Beta-Cluster-Infrastructure board.Nov 25 2014, 8:02 PM
greg raised the priority of this task from Low to Needs Triage.Nov 25 2014, 8:18 PM

I can't repro this anymore, when I append ?tour=gettingstarted to any page (on beta cluster) I don't get any popup at all (?!).

hashar closed this task as Declined.Nov 25 2014, 8:46 PM
hashar claimed this task.

Cant reproduce for now. If we were to write a browser test for GettingStarted I guess we will figure it out a solution. Meanwhile there is no need for the guided tour.

greg triaged this task as Normal priority.Nov 25 2014, 9:00 PM
greg moved this task from To Triage to Done on the Beta-Cluster-Infrastructure board.
greg set Security to None.Nov 25 2014, 10:41 PM

I have added @Mattflaschen @rmoen and @phuedx as members of the MediaWiki-extensions-GettingStarted project.

The 'gettingstarted' tour (that exact name, there are still two other GettingStarted tours, 'gettingstartedtasktoolbar' and 'gettingstartedtasktoolbarve') was removed as part of T55885: Remove 'gettingstarted' tour from GuidedTour and move required messages to GettingStarted.

There is one browser test for GettingStarted, which seems to be fine (https://integration.wikimedia.org/ci/view/BrowserTests/view/-All/job/browsertests-GettingStarted-en.wikipedia.beta.wmflabs.org-linux-firefox-sauce/ passed 23 hours ago).