Page MenuHomePhabricator

Upload Wizard: "Could not understand the file name" when uploading from Flickr when filename includes [, ], (, ),
Closed, ResolvedPublic

Description

Hello,

I got the error message "Could not understand the file name" while uploading http://www.flickr.com/photos/bmnstanislas/8704820386/ from Flickr. Thanks, Yann


Version: master
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=64912

Details

Reference
bz57145

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 2:16 AM
bzimport added a project: UploadWizard.
bzimport set Reference to bz57145.
bzimport added a subscriber: Unknown Object (MLST).
Yann created this task.Nov 17 2013, 2:23 AM
Yann added a comment.Nov 24 2013, 6:28 AM

Could this be correct quickly please? It renders the Wizard useless. It seems a simple bug: just espace any character like [, ], (, ), etc. Thanks, Yann

What makes you think that this is related to [, ], (, ), ?
What are exact steps to reproduce?
How often does this happen with pictured from Flickr in general?

Yann added a comment.Nov 27 2013, 7:58 AM

What makes you think that this is related to [, ], (, ) ?
What are exact steps to reproduce?

This bug happens when importing any page with these characters in the title.

Example: in http://www.flickr.com/photos/bmnstanislas/8704820386/
The title is "La Carrière ou Rue Neuve [M_TS_ES_00106]"

How often does this happen with pictured from Flickr in general?

Every time, with page with these characters.
And it never happens with pages without these characters.

No problem with http://www.flickr.com/photos/bmnstanislas/10741912194/
where the title is "Eglise catholique, album russe de Lisinka Poirel"

Yann added a comment.Dec 12 2013, 8:28 PM

I think this is related to the fact that :><][}{ are not allowed in file names.
In my report above, parenthesis are probably OK.
So if the title of an image on Flickr contains a character which is not allowed, the Wizard should replace this character on the spot.

Jarekt added a comment.May 8 2014, 5:57 PM

I just got the same error message: "Could not understand the file name "Red Rock Canyon, Nevada - Panorama [09].jpg"." when uploading https://www.flickr.com/photos/exothermic/3898751395/in/set-72157622188833782 . Any chance this can be fix?

  • Bug 60022 has been marked as a duplicate of this bug. ***

(In reply to Jarek Tuszynski from comment #5)
Yes, if someone would have time to review I260ba8835489 or comes up with a better solution. The MultimediaTeam appears to be still busy visiting Wikitravel to test MMV there.

Jdforrester-WMF moved this task from Untriaged to Backlog on the Multimedia board.Sep 4 2015, 6:38 PM
Restricted Application added subscribers: Steinsplitter, Matanya, Aklapper. · View Herald TranscriptSep 4 2015, 6:38 PM
MarkTraceur closed this task as Resolved.Dec 3 2015, 5:18 PM
MarkTraceur claimed this task.

I believe this got fixed around the time when we fixed the hashtag issue. Not sure when that was, but I can't reproduce anymore.