Page MenuHomePhabricator

Rethink the upload summaries for photo uploads from mobile
Closed, DeclinedPublic

Description

Various bugs have been popped up about the upload summaries [1,2] provided when an image is uploaded from Special:Uploads or as a lead image for an article.

It seems in the case of Special:Uploads the edit of summary could be more useful and actually provide some detail describing what the image is or where it might be useful.

In the case of uploading from a page in conjunction with the above it would also be nice to know which page the user uploaded from e.g. "Uploaded lead image for X article"

[1] bug 50265
[2] bug 51474


Version: unspecified
Severity: enhancement

Details

Reference
bz58983

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 2:27 AM
bzimport set Reference to bz58983.
bzimport added a subscriber: Unknown Object (MLST).

Designers I wonder whether we should prompt an edit summary as part of the upload workflow? e.g. What kind of articles could this be used for.

It might also help improve the quality of uploads?

  • Bug 51474 has been marked as a duplicate of this bug. ***
  • Bug 50265 has been marked as a duplicate of this bug. ***

bingle-admin wrote:

Prioritization and scheduling of this bug is tracked on Mingle card https://wikimedia.mingle.thoughtworks.com/projects/mobile/cards/1584

I'd be ok with it as long as it was optional, and not doing it didn't cancel the upload.

I don't think its necessary, and I'd rather see us prompt the user for optional categories, or description rather than a edit summary.

So, actual following status?

  • Change upload summary to optional
  • prefill upload summary with page name, if workflow started for lead image

?

(In reply to Jared Zimmerman (WMF) from comment #5)

I'd be ok with it as long as it was optional, and not doing it didn't cancel
the upload.
I don't think its necessary, and I'd rather see us prompt the user for
optional categories, or description rather than a edit summary.

Agreed. Even prompting for a more sane filename would probably be more immediately useful. As far as upload summaries go-they could probably be better even without asking user.

Jdlrobson set Security to None.
Jdlrobson moved this task from Incoming to Epics/Goals on the Readers-Web-Backlog board.
Jdlrobson closed this task as Declined.Jun 4 2015, 10:02 PM
Jdlrobson claimed this task.

Upload feature was removed.