Page MenuHomePhabricator

keyboard focus for mw-createaccount-another is broken
Closed, ResolvedPublic

Description

This ui element in the login screen doesn't have a focused styling, breaking keyboard navigation accessibility.

Seems to have to do with recent mw-ui transition.


Version: 1.23.0
Severity: normal

Details

Reference
bz61374

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 2:54 AM
bzimport set Reference to bz61374.
bzimport added a subscriber: Unknown Object (MLST).
TheDJ created this task.Feb 14 2014, 1:25 PM

MM shouldn't this be "mw-ui-anchor mw-ui-progressive"
Why does it need to be a neutral button? It's a progressive link.

Created attachment 17056
Screenshot of button when focused

I can't reproduce this (tested in Firefox/Iceweasel 31.1.0). Although the hover and focus state are the same, you can still see the focus change as you tab around.

(In reply to Jon from comment #1)

MM shouldn't this be "mw-ui-anchor mw-ui-progressive"
Why does it need to be a neutral button? It's a progressive link.

Probably to maintain emphasis on the primary action. When you're already logged in (the only time you see this button) it's very rare you need to create another account.

Attached:

Anchors do the same thing.. but they are even less emphasised. In mobile these are just standard links [1] so it would be good to be consistent between these two views.

[1] https://en.m.wikipedia.org/wiki/Special:UserLogin

matmarex closed this task as Resolved.Jun 5 2015, 12:23 AM
matmarex claimed this task.

Updated screenshot:

Not exactly a work of art, but the focus indicator is certainly functional. (There are no custom styles now, this is browser's default styling.)