Page MenuHomePhabricator

textarea scrolls up in IE8 on resize
Closed, ResolvedPublic

Description

This bug occurs in Internet Explorer 8 in extension WikiEditor.

Steps to reproduce:

  • Open a long text with WikiEditor for example:

https://de.wikipedia.org/w/index.php?title=Wikipedia:Spielwiese&action=edit&oldid=127895879

  • Scroll in the middle of the text.
  • Position the cursor with the mouse in the middle of the text.
  • Change the size of the browser window

--> The textarea scrolls up a few lines.

Other versions of Internet Explorer are not tested. This bug doesn't occur in other browsers.

This bug doesn't occur in core editor.

This bug occurs since https://gerrit.wikimedia.org/r/109660


Version: master
Severity: minor

Details

Reference
bz61910
Related Gerrit Patches:
mediawiki/extensions/WikiEditor : masterWorkaround for a scrolling bug in IE8 on resize

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 2:54 AM
bzimport set Reference to bz61910.
Fomafix created this task.Feb 25 2014, 2:41 PM

Change 115378 had a related patch set uploaded by Gerrit Patch Uploader:
Workaround for a scrolling bug in IE8 on resize

https://gerrit.wikimedia.org/r/115378

Is adding more hacks for a relatively little used browser, improving the behavior only in a relatively rare situation, worth it in this case?

Jdforrester-WMF moved this task from Backlog to Doing on the WikiEditor board.Dec 2 2014, 8:54 PM

Change 115378 had a related patch set uploaded (by Paladox):
Workaround for a scrolling bug in IE8 on resize

https://gerrit.wikimedia.org/r/115378

Patch-For-Review

matmarex removed a subscriber: matmarex.Dec 4 2014, 11:26 AM

Change 115378 merged by jenkins-bot:
Workaround for a scrolling bug in IE8 on resize

https://gerrit.wikimedia.org/r/115378

matmarex closed this task as Resolved.Dec 6 2014, 3:54 PM
matmarex set Security to None.
GOIII moved this task from Doing to Closed on the WikiEditor board.Apr 3 2016, 8:57 AM