Page MenuHomePhabricator

MultimediaViewer should not display hidden categories, or give them lesser priority
Closed, ResolvedPublic

Description

On Wikimedia Commons, files are tracked for maintenance or internal purposes using hidden categories.

MultimediaViewer appears to display the first three categories based on the alphabetical order.

This results in displaying non-topical categories which do not make much sense. To give a few examples:

The Gallerypreview Gadget (an older, similar attempt to enhance navigation) was working through this through a blacklist [1]. I think ignoring hidden categories is the quickest and safest way.

[1] https://commons.wikimedia.org/wiki/MediaWiki:Gadget-Gallerypreview.js


Version: unspecified
Severity: normal

Details

Reference
bz62277

Event Timeline

bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz62277.
bzimport added a subscriber: Unknown Object (MLST).
JeanFred created this task.Mar 5 2014, 9:41 PM

agr wrote:

More to the point, I and other s believe all visible Commons categories should be displayed in the viewer. There have been many comments to this effect at the MultimediaViewer discussion page.

This is partly caused by the implementation of getForeignCategories, added in git commit 4893d1f of Bug 56598.

I see it's handy to pass along a TitleArray, but this implementation really quite deviates from getCategories in OutputPage, and looses the 'hidden' flag

https://doc.wikimedia.org/mediawiki-core/master/php/html/OutputPage_8php_source.html#l01240

We should really figure out a better more permanent path forward there... Any ideas ?

Tgr added a comment.Jul 15 2014, 6:05 PM

The return value from getForeignCategories() is analogous to getCategories() except that get it returns Title objects while getCategories() just returns the title strings (I don't remember if there was any real reason for the difference or it just seemed cleaner). The hidden flags are returned by OutputPage::getCategoryLinks().

I guess we could add WikiFilePage::getForeignCategoryData() which returns hidden flags as well.

Tgr closed this task as Resolved.Dec 11 2014, 1:40 AM
Tgr claimed this task.

Categories have been removed completely.