VisualEditor: Selection problems involving sfn template in Safari
Closed, ResolvedPublic

Description

Steps to Reproduce:

  1. Using Safari, open https://en.wikipedia.org/w/index.php?oldid=600087421 and scroll to the ==Referenced text== (first) section.
  1. Select a sentence in the first paragraph, including at least one <ref> tag.
  1. Control-click on your choice of "refs" in the next paragraph. (These are all {{sfn}} templates.)
  1. Pretty, isn't it?

Actual Results:
Text all over the page was selected, but not box-type templates.

Reproducible: Sometimes

Unable to reproduce in Firefox.


Version: unspecified
Severity: normal

bzimport set Reference to bz62765.
Whatamidoing-WMF created this task.Via LegacyMar 18 2014, 12:38 AM
Whatamidoing-WMF added a comment.Via ConduitMar 18 2014, 12:41 AM

Created attachment 14845
Screenshot showing strange selection pattern

Attached:

Jdforrester-WMF closed this task as "Resolved".Via WebDec 3 2014, 3:47 AM
Jdforrester-WMF claimed this task.

Seems to be long-fixed?

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.