Page MenuHomePhabricator

Talk overlay conflicts with OverlayManager hide delay
Closed, ResolvedPublic

Description

Open talk overlay click a topic to view it. Click close. Sometimes this also closes the original talk overlay (might be related to tap event).

(We should probably get back button behaviour working on the talk overlay too)


Version: unspecified
Severity: normal

Details

Reference
bz64105

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:17 AM
bzimport added a project: MobileFrontend-beta.
bzimport set Reference to bz64105.
bzimport added a subscriber: Unknown Object (MLST).

bingle-admin wrote:

Prioritization and scheduling of this bug is tracked on Mingle card https://wikimedia.mingle.thoughtworks.com/projects/mobile/cards/1942

  • Bug 67442 has been marked as a duplicate of this bug. ***

Change 153341 had a related patch set uploaded by Florianschmidtwelzow:
Improve Talk Overlay

https://gerrit.wikimedia.org/r/153341

Change 153341 merged by jenkins-bot:
Improve Talk Overlay

https://gerrit.wikimedia.org/r/153341

Reopen, can reproduce after merging routing for TalkOverlay (Ie5dd5b0e66cd192e32dc9288732d16ed49948eec). Tap is removed in MF, so it seems the problem isn't caused by tap :/

Seems to be related to the delay (https://github.com/wikimedia/mediawiki-extensions-MobileFrontend/blob/master/javascripts/Overlay.js#L191) before the element get removed (haven't looked into it for now).

Is this still an issue?

Unhappily yes. You can reproduce it by going to a page with talkOverlay, open the overlay, click "add discussion" and hit return (or click back in your browser) within 1 second.

Change 177870 had a related patch set uploaded (by Florianschmidtwelzow):
Remove waiting when close Overlay

https://gerrit.wikimedia.org/r/177870

Patch-For-Review

Jdlrobson closed this task as Resolved.Dec 15 2014, 8:10 PM
Jdlrobson claimed this task.

Change 177870 merged by jenkins-bot:
Remove waiting when close Overlay

https://gerrit.wikimedia.org/r/177870