Page MenuHomePhabricator

Editing redlinks is broken (in any mode) on mobile
Closed, ResolvedPublic

Description

If you try to edit a redlink or go directly to the URL for editing a non-existent page, it throws a fatal error and sends you to a 404 page.

For example, try going to:
http://en.m.wikipedia.beta.wmflabs.org/wiki/Nullarticle?action=edit&redlink=1

Same behavior in alpha, beta, and stable. (You can follow redlinks from lazy-loaded pages after editing even in stable.)

It looks like it is trying to send the user to Special:MobileEditor/<pagetitle>, which causes a fatal error and then redirects to:
http://en.wikipedia.beta.wmflabs.org/w/undefined

This bug is currently blocking reproduction of VE bug 67639.


Version: unspecified
Severity: major

Details

Reference
bz68249

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:30 AM
bzimport set Reference to bz68249.
bzimport added a subscriber: Unknown Object (MLST).
kaldari created this task.Jul 19 2014, 12:50 AM

bingle-admin wrote:

Prioritization and scheduling of this bug is tracked on Trello card https://trello.com/c/DYlduDYL

Change 147756 had a related patch set uploaded by Florianschmidtwelzow:
Use canUseWikiPage before getWikiPage

https://gerrit.wikimedia.org/r/147756

btw: caused by Change-Id: I509f7dac52b7837bf8b07a790c87f83208568e70

Change 147756 merged by jenkins-bot:
Use canUseWikiPage before getWikiPage

https://gerrit.wikimedia.org/r/147756

Change 148126 had a related patch set uploaded by MaxSem:
Use canUseWikiPage before getWikiPage

https://gerrit.wikimedia.org/r/148126

Change 148126 merged by jenkins-bot:
Use canUseWikiPage before getWikiPage

https://gerrit.wikimedia.org/r/148126