Page MenuHomePhabricator

Bugzilla asterisks interpreted as Phabricator bullet markup
Closed, ResolvedPublic

Description

We want to address these two strings in Bugzilla reports, so that the initial three asterisks "***" don't generate a bullet point in Phabricator:

| *** This bug has been marked as a duplicate of bug 123456 ***
| *** Bug 123456 has been marked as a duplicate of this bug. ***

Old description:

Compare https://bugzillapreview.wmflabs.org/T3347 with its original https://bugzilla.wikimedia.org/show_bug.cgi?id=65088

Note how some lines turn into bulleted lists in Phabricator with trailing asterisks, for example:

  • Bug 65090 has been marked as a duplicate of this bug. ***

That's what happens when Phabricator sees leading **s in markup. In general I like that BZ's awful monospace turns into legible variable-width, and interpreting other ASCII elements conversion makes sense (e.g. quoted > lines become actual quotation). Ideally the conversion should avoid converting double- or triple-asterisks into bullets, or check to see if there are trailing asterisks on the same line and if so add the equivalent of <nowiki>.

Nothing directly corresponds to the latter message, I guess this is a textual representation of "Duplicate of this bug: 65090" ? If so maybe the representation could use something else than ***.

Details

Commits
Unknown Object (Diffusion Commit)

Event Timeline

Spage raised the priority of this task from to Needs Triage.
Spage updated the task description. (Show Details)
Spage added a project: Bugzilla-Preview.
Spage changed Security from none to None.
Spage added a subscriber: Spage.
Qgil triaged this task as Low priority.Oct 25 2014, 6:50 AM
Qgil added a subscriber: Qgil.

This is a cosmetic detail that would be nice to fix if the fix is simple. Especially the expression "Bug NNNNN has been marked as a duplicate of this bug." which is being used frequently.

Qgil assigned this task to chasemp.Oct 29 2014, 9:26 PM
Aklapper moved this task from Ready To Go to Done on the Bugzilla-Preview board.Nov 4 2014, 3:50 PM

this is still weird on imported tasks

Still turned into a bullet point, see e.g. https://bugzillapreview.wmflabs.org/T214#2380

Aklapper moved this task from Done to Ready To Go on the Bugzilla-Preview board.Nov 5 2014, 5:37 PM

are there cases we want to not format which are not

This bug has been marked as a duplicate...

?

Only one more case:

Bug 123456 has been marked as a duplicate of this bug.

with "Bug 123456" being a link of course. That string is in the XML (but not exposed literally in the web UI because we have Bugzilla's InlineHistory extension installed which makes it look nicer without that three stars stuff and such).

I am only aware of Trello link comments in the style of

Prioritization and scheduling of this bug is tracked on Trello card https://trello.com/c/w96Isqis

I don't see any asterisks or stars in there.
I also searched for comments in Bugzilla with at least two asterisks but only found use as list items or Python code pointers to parameters in calls such as

func(*targs, **kargs)

Only other thing I've found is output of "ls" getting changed:

-rw-r--r--. 1 *** ***  9590352 23. Mai 22:01 Lainzer Tiergarten (1) IMG_1478.jpg

becomes:
-rw-r--r--. 1 * * 9590352 23. Mai 22:01 Lainzer Tiergarten (1) IMG_1478.jpg

In T881#19205, @Qgil wrote:

It's linked in the description of the task: https://bugzilla.wikimedia.org/show_bug.cgi?id=65088#c4

Oh, I was thinking in terms of automated comments. There is exactly one comment in Bugzilla which includes "** Tracked at". IMO not worth the hassle.

Qgil updated the task description. (Show Details)Nov 6 2014, 10:02 AM

Ok, I thought that there would be several bugs with that Trello string.

I have edited the description to highlight the only two cases that we want to address, hoping that I got it right. Otherwise, please edit.

chasemp closed this task as Resolved.Nov 10 2014, 3:24 PM
chasemp added a commit: Unknown Object (Diffusion Commit).

Closed by commit rPHTOOLS0fc190dc9980.