Page MenuHomePhabricator

svwiki site script (?) mangles the page when using VisualEditor on a non-existing page
Closed, ResolvedPublic

Description

See this video, it resizes the window when creating a redlink in mainspace. (Not the same if user space). This is only tested on svwp.


Video: https://drive.google.com/open?id=0B9BuJYqrg4ldZEY3UXdOMkliTms&authuser=0


Confirmed:

  • by @Josve05a: Mozilla/5.0 (X11; CrOS x86_64 6680.78.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.102 Safari/537.36
  • by @Howicus: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:37.0) Gecko/20100101 Firefox/37.0
  • by @Lixxx235: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.82 Safari/537.36
  • by @Josve05a: Mozilla/5.0 (iPad; CPU OS 8_3 like Mac OS X) AppleWebKit/600.1.4 (KHTML, like Gecko) Version/8.0 Mobile/12F69 Safari/600.1.4
  • by @Josve05a: Mozilla/5.0 (iPad; CPU OS 8_3 like Mac OS X) AppleWebKit/600.1.4 (KHTML, like Gecko) Mobile/12F69
  • by @Josve05a: Mozilla/5.0 (iPad; CPU OS 8_3 like Mac OS X) AppleWebKit/600.1.4 (KHTML, like Gecko) Mobile/12F69 [FBAN/MessengerForiOS;FBAV/25.0.0.4.14;FBBV/8936291;FBDV/iPad2,5;FBMD/iPad;FBSN/iPhone OS;FBSV/8.3;FBSS/1; FBCR/;FBID/tablet;FBLC/en_US;FBOP/1]
  • by @Josve05a: Mozilla/5.0 (iPad; CPU OS 8_3 like Mac OS X) AppleWebKit/600.1.4 (KHTML, like Gecko) CriOS/41.0.2272.58 Mobile/12F69 Safari/600.1.4
  • by @Lixxx235: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:39.0) Gecko/20100101 Firefox/39.0
  • by @Lixxx235: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:40.0) Gecko/20100101 Firefox/40.0
  • by @Josve05a: Mozilla/5.0 (Windows NT 6.3; WOW64; rv 40.0) Gecko/20100101 Firefox/40.0
  • by @Josve05a: Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko
  • by @TheMesquito: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.90 Safari/537.36

Not reproducible:

Event Timeline

Josve05a created this task.Apr 6 2015, 12:07 AM
Josve05a raised the priority of this task from to Needs Triage.
Josve05a updated the task description. (Show Details)
Josve05a added a project: VisualEditor.
Josve05a added a subscriber: Josve05a.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 6 2015, 12:07 AM
matmarex renamed this task from [Change title] VE resizes the window when creating a redlink in mainspace (svwp) to VE mangles the UI when creating a non-existent page in mainspace (svwp).Apr 6 2015, 12:28 AM
matmarex set Security to None.
matmarex added a subscriber: matmarex.

I can reproduce, but only on sv.wp.

This comment was removed by Josve05a.
Josve05a updated the task description. (Show Details)Apr 6 2015, 12:39 AM
Krenair added a subscriber: Krenair.Apr 6 2015, 2:49 AM

Cannot reproduce...

Nnemo added a subscriber: Nnemo.Apr 6 2015, 12:29 PM
Josve05a triaged this task as High priority.Apr 9 2015, 9:56 PM

I can reproduce this at https://sv.wikipedia.org/wiki/Pwdes?veaction=edit. Screenshot attached.

For reference:

Operating System Macintosh OS X 10.9.5
Screen Resolution 1440 x 900
Web Browser Chrome 42.0.2311.82
Browser Size 1440 x 712
IP Address <removed>
Color Depth 24
Javascript Enabled
Flash Version 17.0.-1
Cookies Enabled
User Agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.82 Safari/537.36

Josve05a updated the task description. (Show Details)Apr 16 2015, 3:43 AM
Josve05a removed a subscriber: Lixxx235.
Josve05a updated the task description. (Show Details)Apr 16 2015, 3:49 AM

Also reproduced in Firefox Developer Edition and Firefox Nightly (on the same machine):

Operating System Macintosh OS X 10.9
Screen Resolution 1440 x 900
Web Browser Firefox 39.0
Browser Size 1440 x 743
IP Address <removed>
Color Depth 24
Javascript Enabled
Flash Version Not Installed
Cookies Enabled
User Agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:39.0) Gecko/20100101 Firefox/39.0


Operating System Macintosh OS X 10.9
Screen Resolution 1440 x 900
Web Browser Firefox 40.0
Browser Size 1440 x 728
IP Address <removed>
Color Depth 24
Javascript Enabled
Flash Version Not Installed
Cookies Enabled
User Agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:40.0) Gecko/20100101 Firefox/40.0

Josve05a updated the task description. (Show Details)Apr 16 2015, 3:57 AM
Josve05a updated the task description. (Show Details)Apr 16 2015, 4:00 AM
Josve05a updated the task description. (Show Details)Apr 16 2015, 4:11 AM
Josve05a added a comment.EditedApr 16 2015, 4:15 AM

This is now confirmed in Safari, Fireox, IE and Chrome on Linux, iOS, Mac, ChromeOS and Windows.

Josve05a updated the task description. (Show Details)Apr 16 2015, 4:27 AM
Josve05a updated the task description. (Show Details)Apr 16 2015, 4:52 AM
Josve05a added a subscriber: CodeLyoko.
CodeLyoko added a comment.EditedApr 16 2015, 4:59 AM

Reproduced on Chrome for Linux at https://sv.wikipedia.org/wiki/Pwdes?veaction=edit. Screenshot attached

Reference:
Operating System Linux Mint 17.1, Kernel 4.0
Screen Resolution 1280x720
Web Browser Chrome 42
Browser Size 1265x581
IP Address <removed>
Javascript Enabled
Flash Version 17.0.0.169
Cookies Enabled
User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.90 Safari/537.36

Deskana raised the priority of this task from High to Unbreak Now!.Apr 16 2015, 5:01 AM
Deskana added subscribers: Jdforrester-WMF, Deskana.

I reproduced this myself (Chrome 41, Mac OS 10.9.5). Went to a random nonexistent page and tapped edit. This isn't just limited to the UI looking bad, it also prevents you from writing anything in the window, so it effectively totally breaks VE.

Given that this is broken in production, I am speculatively increasing priority. @Jdforrester-WMF should assess this ASAP.

Also can reproduce with same result on Firefox for Linux with user agent "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0"

Confirmed with language set to sv, cannot reproduce with language set to en

Ainali added a subscriber: Ainali.Apr 16 2015, 5:41 AM

I turned all my gadgets off and the problem went away. So it's probably an issue with the default gadgets.

Disregard the above, it was a red herring. This problem appears to be related to the user's language choice: I can reproduce this problem if my language is set to Swedish, but not if it's set to English.

Josve05a renamed this task from VE mangles the UI when creating a non-existent page in mainspace (svwp) to VE mangles the UI when creating a non-existent page in mainspace (svwp) and with Swedish language.Apr 16 2015, 7:55 AM
Nemo_bis added a subscriber: Nemo_bis.EditedApr 16 2015, 8:19 AM

LanguageSelector is not deployed, so it can't be at fault. In the video I don't see you using ULS, so that's not relevant either.

I don't know what causes the popup in the video nor what it says. If it's an invitation to translate, it might be related to ContentTranslation. Otherwise, it's a VE issue.

Given the mismatch between sidebar and background, this seems a typical unclosed div or similar...

It looks like a site script issue (this is why it only affects you if your user language is the content language of the wiki, unlike gadgets which run whichever language you have set).

I've not been able to narrow it down yet. It's plausible that this edit to Common.js may have broken it, but I can't see why if so.

(Normally site screw-ups like this aren't tracked in Phabricator, but I don't see a reason to close this task whilst it's worked out.)

Jdforrester-WMF renamed this task from VE mangles the UI when creating a non-existent page in mainspace (svwp) and with Swedish language to svwiki site script (?) mangles the page when using VisualEditor on a non-extant page.Apr 16 2015, 3:20 PM
Jdforrester-WMF removed a project: I18n.
Jdforrester-WMF closed this task as Resolved.Apr 16 2015, 4:25 PM
Jdforrester-WMF claimed this task.
Jdforrester-WMF added a subscriber: Catrope.

Fix verified. Thank you!

Great to have this fixed, thanks! So if I understand it correctly, this </div> error has been around since 30 May 2014 and just recently been discovered or am I missing something here?

Josve05a added a comment.EditedApr 16 2015, 10:41 PM

Fix confirmed on at least Mozilla/5.0 (Windows NT 6.3; WOW64; rv 40.0) Gecko/20100101 Firefox/40.0, however I was affected by T93964: Progress bar moves backwards sometimes or something, the bar went backwards :P

Great to have this fixed, thanks! So if I understand it correctly, this </div> error has been around since 30 May 2014 and just recently been discovered or am I missing something here?

Looks like it. :-(

gpaumier moved this task from Backlog to Triaged on the Notice board.Apr 17 2015, 3:22 PM
Nemo_bis renamed this task from svwiki site script (?) mangles the page when using VisualEditor on a non-extant page to svwiki site script (?) mangles the page when using VisualEditor on a non-existing page.Apr 18 2015, 5:56 AM
Nemo_bis added a subscriber: CodeLyoko.
gpaumier moved this task from Triaged to Archive on the Notice board.Apr 23 2015, 9:15 PM