Page MenuHomePhabricator

Link in Source Column shows link from Target Wikipedia
Closed, ResolvedPublic

Description

While opening link from Source column content, it should be from Source Wikipedia instead of Target (Which makes links non-working).

See:

Link-as-target-language.png (585×636 px, 117 KB)

Event Timeline

KartikMistry raised the priority of this task from to Needs Triage.
KartikMistry updated the task description. (Show Details)
KartikMistry added a subscriber: KartikMistry.

What do you meant by links not working?
Can you explain what is wrong in screenshot? Is this a screenshot of source column?
How did you open the link? When I control+click a link in source column I see it open in source language wiki.

Amire80 added a subscriber: Amire80.

@KartikMistry, can you please add details?

OK, it's not resolved, and I can reproduce it consistently myself, and it's actually quite simple:

Expected: the link from the English article column to "Moscow" must point to https://en.wikipedia.org/wiki/Moscow .
Observed: It points to https://he.wikipedia.org/wiki/Moscow - 'he' instead of 'en'.

Amire80 raised the priority of this task from Low to Medium.Jul 1 2015, 1:09 PM

Actually, @KartikMistry's first screenshot shows it :)

Change 241613 had a related patch set uploaded (by Amire80):
Set absolute URLs for source links

https://gerrit.wikimedia.org/r/241613

Change 241613 merged by jenkins-bot:
Set absolute URLs for source links

https://gerrit.wikimedia.org/r/241613