Page MenuHomePhabricator

Source editor should remain visible, but disabled, while VE is loading
Closed, ResolvedPublic

Event Timeline

Esanders raised the priority of this task from to Needs Triage.
Esanders updated the task description. (Show Details)
Esanders added a subscriber: Esanders.
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Mattflaschen-WMF triaged this task as Medium priority.Apr 28 2015, 5:47 PM
Catrope claimed this task.Apr 28 2015, 9:16 PM

Change 207295 had a related patch set uploaded (by Catrope):
Keep source editor visible but disabled while VE loads

https://gerrit.wikimedia.org/r/207295

Change 207295 merged by jenkins-bot:
Keep source editor visible but disabled while VE loads

https://gerrit.wikimedia.org/r/207295

Checked on http://en.wikipedia.beta.wmflabs.org/wiki/Talk:Flow_QA


My understanding of expected behaviour:

  1. I type something in Source editor - and click to switch to VE.
  2. My typed content is faded but keeps being displayed until VE is fully loaded.

I attached QuickTime screen recording of how it looks now. 'Post a new message to "Talk: Flow QA" ' is displayed instead of the typed content.

Change 208031 had a related patch set uploaded (by Catrope):
Make editor switching look nicer

https://gerrit.wikimedia.org/r/208031

Change 208031 merged by jenkins-bot:
Make editor switching look nicer

https://gerrit.wikimedia.org/r/208031

DannyH closed this task as Resolved.May 6 2015, 8:35 PM
DannyH added a subscriber: DannyH.

works on Beta