Page MenuHomePhabricator

jessie installs fail - mirror issue due to jessie release?
Closed, ResolvedPublic

Description

Installs of jessie are now failing to work, due to mirror error during install.

I'll paste the error later, right now I'm troubleshooting a different partman issue and I'm simply making this task so it isn't forgotten. (Whoever goes to install a Jessie server will see the issue.)

Event Timeline

RobH created this task.Apr 28 2015, 10:29 PM
RobH raised the priority of this task from to Unbreak Now!.
RobH updated the task description. (Show Details)
RobH added a project: acl*sre-team.
RobH added subscribers: RobH, akosiaris, mark and 4 others.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 28 2015, 10:29 PM

Confirmed. I had carbon do a one off mirror from mirrors.kernel.org as ftp2.us.debian.org mirror failed but the issue was not resolved

BBlack assigned this task to faidon.Apr 29 2015, 2:48 PM

Assigning to Faidon since I think he knows the most about our jessie installer setup. Feel free to re-assign further :)

I've checked and fixed some things that I found at random (newer d-i image from stable, unset the udeb suite, checked the mirror status) but it would help... having an error message or a description of what exactly went wrong :)

If you need a node to test, oxygen is ready for a jessie install! I was going to try to do this later today.

faidon closed this task as Resolved.Apr 29 2015, 3:49 PM

OK, @akosiaris gave me logs and helped me debug, so I tracked this down to:

root@carbon:~# wget -qO- http://mirrors.wikimedia.org/debian/dists/oldstable/Release | grep -E '^(Suite|Codename):'
Suite: oldstable
Codename: wheezy

root@carbon:~# http_proxy=webproxy.eqiad.wmnet:8080 wget -qO- http://mirrors.wikimedia.org/debian/dists/oldstable/Release | grep -E '^(Suite|Codename):'
Suite: stable
Codename: wheezy

Purging webproxy's cached fixed it.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptJul 29 2016, 8:19 PM