Add "Discover" screen to iOS App which allows users to explore feeds of relevant articles
Closed, ResolvedPublic

Description

Definition Progress

  • Summary
  • Rationale
  • Success Metrics
  • External Dependencies
  • Unknowns
  • Product Plan
    • Prototyping
    • MVP
    • User stories
    • User Story Phab Tickets
    • Metrics Implementation
    • Metrics Phab Tickets
    • Estimates
    • Delivery Date

Summary

Add a screen with feeds powered by recently viewed articles, nearby, "Today" content to give users something to browse when they do not have a specific destination.

Goal Visibility

External

Rationale

Product has expressed an interest in making the iOS app "A destination". Meaning that users should open up the app with no specific task or goal in mind.

To facilitate this, a "Discover" screen was proposed to surface content that is likely to be interesting to the user based on "passive" input (browsed, articles, location, time)

This is also viewed as a way to differentiate the apps from the web.

Success Metrics

Engagement with Discover screen should be greater than engagement with the "W" menu

Demonstrates that users find the Discover screen more engaging than the "W" menu which it replaces (as measured by clicks)

Engagement with Discover screen is greater than engagement with the Today Screen

Demonstrates that users find the Discover screen more engaging than the today screen which it replaces

When the Discover Screen is viewed, 5% of users engage with it before performing another task

Demonstrates that users are opening the app with the primary goal of engaging with the Discover screen

Increase the number of articles browsed per session

Demonstrates that the Discover screen is encouraging users to browse more content overall

External Dependencies

Related Content Service - it should not need additional work for the MVP.

Unknowns

How "good" the related Article API is. Or rather how relevant. We will need to implement a plan to test in beta and implement analytics to measure engagement.

Order of content. What content should be "above the fold".

Product Plan

Prototyping

Prototypes were completed by design in Q3/Q4.

MVP

  • Create discover screen with content
    • Today
    • Nearby
    • Content related to saved pages
    • Content related to browsing history
  • Remove redundant items in "W" menu
  • Analytics to measure engagement

User Stories

User StoryTicket
As a curious apps reader, I'd like a feed of articles/facts/images so that I can learn more about topics I'm interested inT93327
As a reader, I'd like suggestions for what I can read next based on my previously read articlesT90256
As a user I should be asked before displaying content in the discovery feed that is based on my personal data. I should also be able to change my decision laterT104816
As a user, I want to see nearby articles on the Discover screenT104817

Metrics Implementation

Measure taps on any item on the discover screen. Be sure to associate taps with sessions.

Timeline Estimate

TaskEstimate
Mockups2 weeks
Development4 weeks
Beta Testing1 week

Delivery Estimate

August 2015

Related Objects

Fjalapeno created this task.Jul 1 2015, 3:37 AM
Fjalapeno updated the task description. (Show Details)
Fjalapeno raised the priority of this task from to Needs Triage.
Fjalapeno added a project: Mobile-App-Goals.
Fjalapeno added a subscriber: Fjalapeno.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 1 2015, 3:37 AM
Fjalapeno updated the task description. (Show Details)Jul 1 2015, 3:58 AM
Fjalapeno set Security to None.
Fjalapeno updated the task description. (Show Details)
Fjalapeno updated the task description. (Show Details)Jul 1 2015, 9:35 PM
Fjalapeno updated the task description. (Show Details)Jul 1 2015, 9:39 PM
Fjalapeno updated the task description. (Show Details)Jul 1 2015, 9:46 PM
Fjalapeno renamed this task from Add "Discover" screen with feeds of relevant articles for users to explore to Add "Discover" screen to iOS App which allows users to explore feeds of relevant articles.Jul 2 2015, 6:17 PM
Fjalapeno moved this task from Q1 Android to Q1 iOS on the Mobile-App-Goals board.Jul 3 2015, 5:43 PM
Fjalapeno added a project: Epic.
Fjalapeno updated the task description. (Show Details)Jul 5 2015, 9:36 PM
Fjalapeno updated the task description. (Show Details)Jul 5 2015, 9:39 PM
Fjalapeno updated the task description. (Show Details)
Fjalapeno updated the task description. (Show Details)Jul 5 2015, 10:00 PM
Josve05a updated the task description. (Show Details)Aug 22 2015, 11:19 PM
JKatzWMF updated the task description. (Show Details)Sep 18 2015, 4:35 PM
Tbayer added a subscriber: Tbayer.Sep 24 2015, 11:33 PM
dr0ptp4kt moved this task from Backlog to Current Quarter on the Reading-Admin board.
JMinor moved this task from Q1 iOS to Q2 iOS on the Mobile-App-Goals board.Oct 21 2015, 7:25 PM
Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptNov 18 2015, 9:02 PM
JMinor closed this task as Resolved.Jan 26 2016, 10:37 PM
JMinor claimed this task.
JMinor added a subscriber: JMinor.

Basics of the feed, now called "Explore" have been implemented and are in beta.