Page MenuHomePhabricator

When accessing talk page through echo, the yellow "new message" notification doesn't go away until the next page view
Closed, ResolvedPublic

Description

This is a problem I have noticed on Wikipedia since about 2-3 weeks ago.

When I have a new message on my talk page, I see a red number in the Echo notification area as well as a yellow reminder. When I open the Echo notification list and click on the item about my new message I will be directed to my talk page. The Echo notification number changes to zero (as desired) but the yellow message does not go away (not desired). See screenshot from Fa WP.

If I got to any other page, that yellow message is gone. It is only on the first visit to my User Talk page that it remains there.

Details

Related Gerrit Patches:

Event Timeline

Huji created this task.Aug 1 2015, 2:33 PM
Huji raised the priority of this task from to Needs Triage.
Huji updated the task description. (Show Details)
Huji added a project: Notifications.
Huji added a subscriber: Huji.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptAug 1 2015, 2:33 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Does it go away when reloading the page and bypassing your browser cache?

Huji added a comment.Aug 3 2015, 2:17 PM

Reloading makes it go away. Any page loads after that make it go away indeed.

Btw, I also noticed it on Meta today.

Mattflaschen-WMF reopened this task as Open.Aug 5 2015, 9:52 PM

This is about the yellow bar not going away when the user talk page is visited. It's not the same as the other one.

Huji added a comment.Aug 5 2015, 10:11 PM

The root cause may be the same.

Catrope triaged this task as Normal priority.Aug 5 2015, 11:49 PM
Catrope added a subscriber: Catrope.
Legoktm claimed this task.Sep 14 2015, 5:27 PM

I think this is a regression from rMW64bf3a12b514: Defer user_newtalk updates in clearNotification() to post-send. Previously the user_newtalk flag would have already been cleared, so Echo would think you don't have any new messages.

Change 238194 had a related patch set uploaded (by Legoktm):
Don't show orange alert if you are viewing your user talk page

https://gerrit.wikimedia.org/r/238194

Legoktm renamed this task from When accessing talk page through echo, the yellow "new message" notification doesn't go away to When accessing talk page through echo, the yellow "new message" notification doesn't go away until the next page view.Sep 14 2015, 5:35 PM
Legoktm set Security to None.
Elitre added a subscriber: Elitre.Sep 15 2015, 9:24 AM

Change 238194 merged by jenkins-bot:
Don't show orange alert if you are viewing your user talk page

https://gerrit.wikimedia.org/r/238194

Checked in beta - getting (via clicking on a specific message notification, or via clicking on Notification, or via Search) to your Talk page will remove yellow/orange 'You have new messages' label.

DannyH closed this task as Resolved.Sep 22 2015, 6:32 PM
DannyH added a subscriber: DannyH.