Page MenuHomePhabricator

FOUC of VE's edit tab on page load caused by EducationProgram ext, made visible by the newly async RL model
Closed, ResolvedPublic8 Story Points

Event Timeline

Jdforrester-WMF raised the priority of this task from to Unbreak Now!.
Jdforrester-WMF updated the task description. (Show Details)
Jdforrester-WMF moved this task to TR0: Interrupt on the VisualEditor board.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 5 2015, 2:35 AM
Jdforrester-WMF added subscribers: Krinkle, Esanders.

The edit tab is swapped server-side by VisualEditor in PHP. The JS code is only used to fix it up for cached unedited articles (upto 30 days) following a configuration change such as enabling in a namespace, or enabling by default.

That use case was considered and we figured that'd be okay given it's not common in production in general. And when it happens it automatically drops off following cache roll over.

Does VisualEditor have any JavaScript code that (almost) always changes the appearance of the initial page load? If so, let's identify that and work to get rid of it as that is a bad practice. It should be done with HTML and CSS instead.

Well, you wrote it…

greg added a subscriber: greg.Aug 6 2015, 4:09 PM
greg added a subscriber: mmodell.Aug 6 2015, 4:22 PM

FYI: This task is considered a blocker for the upcoming (August 11th) train deployment to WMF wikis. If this task is not fixed before then I will have to hold the train.

Krinkle added a comment.EditedAug 6 2015, 4:40 PM

Well, you wrote it…

When I wrote it, there was no flash. The js code and PHP code were functionally equivalent. The JS code is a no-op – unless the wiki's configuration changed recently (namespace, VE default etc.) and the user is anonymous and they're viewing a not-recently-changed cached page.

Krinkle claimed this task.Aug 6 2015, 4:41 PM

Well, you wrote it…

When I wrote it, there was no flash. The js code and PHP code were functionally equivalent. The JS code is a no-op – unless the configuration changed recently and the user is anonymous and they're viewing a not-recently-changed cached page.

Yeah, sorry for being snappy. I've skimmed the code and can't see how it's not being set.

Change 229954 had a related patch set uploaded (by Krinkle):
Never unconditionally 'return false' from interface hooks

https://gerrit.wikimedia.org/r/229954

Change 229955 had a related patch set uploaded (by Krinkle):
Never unconditionally 'return false' from interface hooks

https://gerrit.wikimedia.org/r/229955

Change 229954 merged by jenkins-bot:
Never unconditionally 'return false' from interface hooks

https://gerrit.wikimedia.org/r/229954

Change 229955 merged by jenkins-bot:
Never unconditionally 'return false' from interface hooks

https://gerrit.wikimedia.org/r/229955

Jdforrester-WMF renamed this task from [Regression pre-wmf18] FOUC of VE's edit tab on page load caused (?) by newly async RL model to FOUC of VE's edit tab on page load caused by EducationProgram ext, made visible by the newly async RL model.Aug 6 2015, 9:26 PM
Jdforrester-WMF closed this task as Resolved.
Jdforrester-WMF edited a custom field.