Page MenuHomePhabricator

No such file or directory - i18n/af.json (Errno::ENOENT)
Closed, ResolvedPublic1 Story Points

Event Timeline

zeljkofilipin raised the priority of this task from to Normal.
zeljkofilipin updated the task description. (Show Details)
zeljkofilipin added subscribers: Amire80, Vikassy.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 4 2015, 2:07 PM
Amire80 claimed this task.Sep 4 2015, 2:09 PM

Oh drat, we didn't implement fallback in Ruby.

Jdforrester-WMF edited a custom field.
Vikassy claimed this task.Sep 25 2015, 9:58 PM

Ah ! Forgot about this one. I will take care of this.

Change 241248 had a related patch set uploaded (by Vikassy):
[BrowserTest] Use english if i18n file does not exists to convert the text

https://gerrit.wikimedia.org/r/241248

zeljkofilipin closed this task as Resolved.Oct 12 2015, 3:14 PM
zeljkofilipin added a subscriber: zeljkofilipin.

Change 241248 merged by jenkins-bot:
[BrowserTest] Use English if i18n file does not exists to convert the text

https://gerrit.wikimedia.org/r/241248

zeljkofilipin reopened this task as Open.Oct 12 2015, 4:00 PM

My mistake. I am sure I have tested the patch, but now that it is merged, the jobs are still failing.

The error message is now slightly different:

15:22:40 No such file or directory - ../../i18n/.json (Errno::ENOENT)

Change 245499 had a related patch set uploaded (by Zfilipin):
Delete failing VisualEditor browsertests Jenkins jobs

https://gerrit.wikimedia.org/r/245499

Weird ! I had tested this too.

@zeljkofilipin: But error seems to be different in https://integration.wikimedia.org/ci/view/BrowserTests/view/language-screenshot/job/browsertests-VisualEditor-language-screenshot-os_x_10.10-firefox/77/LANGUAGE_SCREENSHOT_CODE=en,label=contintLabsSlave%20&&%20UbuntuTrusty/console

Can you please share the link where you found the above error ? (15:22:40 No such file or directory - ../../i18n/.json (Errno::ENOENT))

Jdforrester-WMF raised the priority of this task from Normal to Unbreak Now!.Oct 19 2015, 1:46 AM
Jdforrester-WMF removed a project: Patch-For-Review.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

This change has broken every single browser test on all platforms now for a week. Could you please fix it or revert?

Change 245499 merged by jenkins-bot:
Delete failing VisualEditor browsertests Jenkins jobs

https://gerrit.wikimedia.org/r/245499

@Vikassy while resolving T94162 I have deleted all VisualEditor jobs except one (that does not have this error message). Can you reproduce the error locally?

These 2 are different issue. Pointing to the correct issue: T90577 (this is where the problem is)

Change 247612 had a related patch set uploaded (by Hashar):
Revert "Delete failing VisualEditor browsertests Jenkins jobs"

https://gerrit.wikimedia.org/r/247612

Change 247612 abandoned by Hashar:
Revert "Delete failing VisualEditor browsertests Jenkins jobs"

Reason:
Per Zeljko above, lets follow up on T94162 for the test breakages and T114362 for lack of IE/Safari support.

https://gerrit.wikimedia.org/r/247612