Page MenuHomePhabricator

Free form text field in QuickSurveys
Closed, DeclinedPublic

Description

Add the option of showing free form (text entry) answers to QuickSurveys. This feature is needed for us to be able to collect data without steering the participant in a specific direction. Questions like: Why are you reading this article? or What is the first word that comes to your mind when reading this article? etc. need an initial data collection in the form of free form entries.

Event Timeline

leila created this task.Oct 14 2015, 3:37 PM
leila raised the priority of this task from to Needs Triage.
leila updated the task description. (Show Details)
leila added subscribers: leila, Jdlrobson, atgo and 3 others.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 14 2015, 3:37 PM
Jdlrobson triaged this task as Low priority.Oct 14 2015, 4:22 PM
leila added a subscriber: JKatzWMF.Oct 16 2015, 5:11 PM

@JKatzWMF please let us know what the timeline for this task to be done is so we can update the plans for T113443 accordingly. If we can know this info today, that's ideal.

@leila the team responsible is at an offsite throughout the week, but @atgo, @Tnegrin and I are trying to get some understanding through @dr0ptp4kt by EOD, though.

The Quick Survey extension supports the notion of linking to an offsite survey, such as Qualtrics, for free form text entry.

@leila after discussing with the ^, we decided we cannot commit to this feature, this quarter. Please follow up with @atgo if you have any questions/concerns.

@JKatzWMF , @atgo Could you give us the reasons for why you made this decision? If you already have the infrastructure for logging a categorical survey response, adding a text field response seems like it should not take a lot of effort. If you think it would be more appropriate to discuss this in person, lets schedule a quick meeting tomorrow to discuss.

leila added a comment.Oct 20 2015, 4:49 AM
This comment was removed by leila.

@ellery @leila the decision was made yesterday because @dr0ptp4kt estimated the change size as a 'medium'. The team is already stretched this quarter with regard to our goals and adding new features to the tool is not part of our goals, so prioritizing a medium task feels irresponsible when there isn't an obvious candidate for something that will NOT get done as a result. That is why, at this point, I do not feel comfortable promising that the team will get to it. That being said, your work in this area sounds very interesting and valuable to us--happy to discuss more.

Thinking tactically:

  • Would the offsite survey mode be suitable for your purposes short run (presuming there's Qualtrics availability of additional surveying)?
  • Is this something you would want in the queue for consideration for Q3 FY 2015-2016?

I talked to Bob West -- there are some other options we can investigate for
populating the lists.

dr0ptp4kt set Security to None.
dr0ptp4kt moved this task from Backlog to Next Quarter Candidates on the Reading-Admin board.

Questions:

  • How would this free text field fit into the survey? Does it appear at all times or does it only get revealed when the "other" option is clicked?
  • Currently clicking a button sends the survey - how would the UX work for the other field? When would it send?
  • Is their a limit to the size of the other field?
  • What happens if a user enters more than the limit? e.g. writes a huge essay - do we prevent them from sending the data or do we throw it away silently. If the former we'll need to think about how that looks from the users perspective.

IIRC individual Event Logging fields should be truncated at 191 characters to play it safe. @Nuria, can you confirm?

@dr0ptp4kt the question is more around do you need validation/input to the user or to drop the data. There is going to be some limit imposed...

atgo added a comment.Oct 27 2015, 4:45 PM

Hey team- I'm following up on this in email, but it may not block the
initial survey work by @leila. Will confirm shortly.

atgo added a comment.Oct 27 2015, 4:46 PM

And confirmed - this is not a blocker for the surveys. We can remove this from upcoming work @JKatzWMF @KLans_WMF

This comment was removed by chasemp.
This comment was removed by chasemp.
DarTar moved this task from Staged to Radar on the Research board.Nov 12 2015, 11:14 PM

Since we decided not to do this in QuickSurveys, I'm going to Decline the task. :-)

leila closed this task as Declined.Jan 28 2016, 11:33 PM