Page MenuHomePhabricator

Clicking Flow "new replies" notifications highlights only the most recent reply
Closed, ResolvedPublic

Description

I sometimes receive Flow notifications along the lines of "Example and 2 others responded on XYZ". Clicking on this notification highlights only the most recent reply, rather than highlighting all replies bundled into the notification. This makes actually following a conversation annoyingly difficult, as I have to remember the how long ago I last looked at the conversation and look through the entire topic for replies with a new time indication.

The same likely happens if one person has posted more than one reply, a notification "Example responded on XYZ" (which is ok) that highlights only the most recent of their replies (which isn't).

I think it used to highlight all replies in the past, making this a regression, although that might just be my memory playing tricks on me. Even in past, though, I recall being annoyed that it jumped to the most recent post even if other highlighted replies are higher on the page.

Event Timeline

Anomie created this task.Jan 20 2016, 3:56 PM
Anomie updated the task description. (Show Details)
Anomie raised the priority of this task from to Needs Triage.
Anomie added a project: StructuredDiscussions.
Anomie added a subscriber: Anomie.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJan 20 2016, 3:56 PM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald Transcript
Catrope set Security to None.
Catrope removed a subscriber: Quiddity.

Anomie, what's your web browser and OS? I'm having problems with these new notifications because the Echo URLs get redirected, and Safari drops the redirects.

and Safari drops the redirects.

What do you mean by this? Does Safari drop the fragment (the part after the #) from redirect URLs or something?

Anomie, what's your web browser and OS?

Firefox (well, really Iceweasel) 44.0b6 on Debian.

SBisson triaged this task as High priority.
SBisson claimed this task.

I just tested this locally and the primary link of the notification did highlight all replies bundled in that notification.

From the wording you used (Example and 2 others responded on XYZ), I can see that the site you experienced the problem on was not updated with the latest version of the flow notifications.

Please let me know where this happened so I can see what's going on there.

Anomie added a comment.EditedJan 25 2016, 8:34 PM

I particularly noticed it on officewiki, but I see the same on mediawiki.org.

For a live example, I just clicked a notification with a (sanitized) message "Example and 3 others responded on XYZ" and got this link that is highlighting only one post rather than four.

You should get a new version on those wikis tomorrow. I think it'll be fixed. If not, I'll investigate more.

SBisson added a comment.EditedJan 27 2016, 1:50 PM

It looks like the changes to Flow notifications will be deployed next week. Sorry for the delay.

You should now see the new message and new links for this kind of notification (multiple replies). Clicking on it should go to the topic page with the new posts highlighted by a thin blue vertical line on the left.

Please let us know if it works as expected for you and what you think of the new messages. We hope you like it but if you don't we also want to know.

Anomie added a comment.Feb 4 2016, 3:29 PM

It seems to function. I have no opinion yet on the new messages.

SBisson closed this task as Resolved.Feb 4 2016, 3:32 PM

It seems to function. I have no opinion yet on the new messages.

Fair enough.

I'll close this one now as it was resolved by T121950: Rephrase Flow notifications, move content from body into header

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptFeb 4 2016, 3:33 PM

@Catrope: Yes, Safari drops the fragment (the part after the #) from redirect URLs.

Example: I received "thanks" for a post in Flow. Echo gives me a link to https://www.mediawiki.org/w/index.php?title=VisualEditor/Feedback&workflow=sxe4bxc7rd2y6vsy#flow-post-sxe8utels4yikezn – but when I click it, I actually end up at just https://www.mediawiki.org/wiki/Topic:Sxe4bxc7rd2y6vsy

It would highlight properly if Echo instead gave me a link to https://www.mediawiki.org/wiki/VisualEditor/Feedback#flow-post-sxe8utels4yikezn