Page MenuHomePhabricator

Extra lines being inserted in edited transclusion wikitext serialisation when “block” format due to unexpected extra spaces
Closed, ResolvedPublic0 Story Points

Description

I’ve seen two problematic editions on articles where the infobox’s templatedata contains format: block:

The diff is unreadable… I guess this is caused by the space on each line before the delimiting pipe?

Event Timeline

Ltrlg created this task.Feb 28 2016, 12:25 PM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 28 2016, 12:25 PM
matmarex triaged this task as High priority.Feb 29 2016, 8:39 PM
matmarex edited projects, added Parsoid; removed VisualEditor.

Interesting ... this looks like some regexp issue in Parsoid.

Yes, confirmed. This is a bug because of the leading space before the pipe. Will fix and add new tests. This will be deployed on Wednesday.

Jdforrester-WMF set the point value for this task to 0.

Change 273975 had a related patch set uploaded (by Subramanya Sastry):
T128319: Fix fragile tests for non-block-format transclusions

https://gerrit.wikimedia.org/r/273975

Elitre added a subscriber: Elitre.Feb 29 2016, 9:31 PM

Change 273975 merged by jenkins-bot:
T128319: Fix fragile tests for non-block-format transclusions

https://gerrit.wikimedia.org/r/273975

For the first one, it was then fixed by https://fr.wikipedia.org/w/index.php?title=Windows_10&diff=prev&oldid=123794378 later (also via VE and Parsoid). Not quite sure why?

For the first one, it was then fixed by https://fr.wikipedia.org/w/index.php?title=Windows_10&diff=prev&oldid=123794378 later (also via VE and Parsoid). Not quite sure why?

That is a wikitext edit as far as I can tell.

Jdforrester-WMF renamed this task from Lines inserted in “block” format to Extra lines being inserted in edited transclusion wikitext serialisation when “block” format due to unexpected extra spaces.Mar 1 2016, 1:15 AM
Jdforrester-WMF assigned this task to ssastry.
ssastry closed this task as Resolved.Mar 1 2016, 6:58 PM
ssastry removed a project: Patch-For-Review.

This fix has been deployed.