Page MenuHomePhabricator

Add confirmation feature to Nuke extension
Closed, ResolvedPublic

Description

Please add the most annoying feature in MediaWiki (CAPTCHA) to the place it should be - Nuke.
Administrators can accidentally cause massive damage (as already happened too many times), and it is important to let them confirm in a more than safe way that they are sure

Event Timeline

eranroz created this task.Apr 6 2016, 9:03 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 6 2016, 9:03 PM

CAPTCHA isn't meant to be "Are you sure". It's meant to be "Are you a human". If you want a bigger confirmation step, please ask for something different (like typing the username of the user to nuke again).

Aklapper renamed this task from CAPTCHA for NUKE to Add CAPTCHA feature to Nuke extension.Apr 7 2016, 8:46 AM

Change 329387 had a related patch set uploaded (by Ladsgroup):
Ask for confirmation when nuking

https://gerrit.wikimedia.org/r/329387

I added a patch which makes Nuke asks for confirmation. CAPTCHA would be too much as pointed out by @Jackmcbarn

@Ladsgroup, please, add the number of deleted pages into the confirmation message. The problem is almost always when somebody wants to delete five pages but deletes five hundred. Thank you.

@Ladsgroup, please, add the number of deleted pages into the confirmation message. The problem is almost always when somebody wants to delete five pages but deletes five hundred. Thank you.

Done

Thanks a lot.

Change 329387 merged by jenkins-bot:
[mediawiki/extensions/Nuke@master] Ask for confirmation when nuking

https://gerrit.wikimedia.org/r/329387

Jdforrester-WMF renamed this task from Add CAPTCHA feature to Nuke extension to Add confirmation feature to Nuke extension.Oct 6 2017, 5:27 PM
Jdforrester-WMF assigned this task to Ladsgroup.
Jdforrester-WMF removed a project: Patch-For-Review.
Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptOct 6 2017, 5:27 PM
Jdforrester-WMF closed this task as Resolved.Oct 6 2017, 5:28 PM
IKhitron added a subscriber: Jdforrester-WMF.EditedDec 22 2017, 1:54 PM

Hi, @Ladsgroup, @Jdforrester-WMF. I just used Nuke first time from this task was closed, and I did not see any confirmation message, the pages just were deleted. Tryed a couple of times on hewiki. Thank you.

Change 405602 had a related patch set uploaded (by Ladsgroup; owner: Amir Sarabadani):
[mediawiki/extensions/Nuke@master] Fix wrong use of mw.msg

https://gerrit.wikimedia.org/r/405602

Sorry, I made an oversight about this. It's fixed by this patch that I hope I can get merged soon.

Change 405602 merged by jenkins-bot:
[mediawiki/extensions/Nuke@master] Fix wrong use of mw.msg

https://gerrit.wikimedia.org/r/405602

Change 478967 had a related patch set uploaded (by Thiemo Kreuz (WMDE); owner: Thiemo Kreuz (WMDE)):
[mediawiki/extensions/Nuke@master] Fix broken message showing {{PLURAL:…}} in plain text

https://gerrit.wikimedia.org/r/478967

Change 478967 merged by jenkins-bot:
[mediawiki/extensions/Nuke@master] Fix broken message showing {{PLURAL:…}} in plain text

https://gerrit.wikimedia.org/r/478967