Page MenuHomePhabricator

The characters in [3] (inline footnote) linebreaks
Closed, InvalidPublic

Description

The characters in footnotes should not be "breakable" (use nbsp, but without the space or something)


(above image on https://sv.wikipedia.org/wiki/Johannes_Weltzer in Chrome set to 90% zoom)

(above image on https://sv.wikipedia.org/wiki/Hamra_nationalpark in Chrome set to 175% zoom)

Event Timeline

Josve05a created this task.Apr 9 2016, 4:04 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 9 2016, 4:04 PM
Josve05a updated the task description. (Show Details)Apr 9 2016, 9:14 PM
Josve05a updated the task description. (Show Details)Apr 9 2016, 9:23 PM
Wostr added a subscriber: Wostr.Apr 10 2016, 11:02 AM
matmarex added a subscriber: matmarex.

Looks like a browser bug to me. I can't reproduce this using any other browser (checked Firefox, Opera 12, IE 11). The element clearly has 'white-space: nowrap' set and thus shouldn't ever wrap. Funnily, removing it fixes the issue in Chrome (but potentially breaks other browsers).

I can now reprodue this in Chrome on another computer on https://sv.wikipedia.org/wiki/Klas_B%C3%B6%C3%B6k

Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36

Screen Resolution:	1366 px x 768 px
Browser Window:	1349 px x 653 px

So, yeah. Seems to be a Chrome-specific issue :/
Something we can fix, or should it be upstreamed somehow?

I don't see how we could do anything here. A bug report upstream would make sense, if there isn't one yet (http://crbug.com/).

jayvdb edited projects, added Upstream; removed Design.May 7 2016, 10:15 AM
Izno moved this task from Unsorted backlog to Defect backlog on the Cite board.Aug 22 2016, 3:55 PM
Aklapper closed this task as Invalid.Sep 1 2019, 11:18 PM

I don't see how we could do anything here.

Hence closing this task as invalid.

Ebraminio added a subscriber: Ebraminio.EditedOct 2 2019, 9:34 PM

@Aklapper, no relevant in 2019 as far as can be seen, feel free to CC me to other Chrome 76 related ones though.

@Ebraminio: I'd feel bad CC'ing you on too many tasks - Feel free to watch Browser-Support-Google-Chrome (and/or Browser-Support-Android-Google-Chrome ) if you're interested, I'd say? :)