Page MenuHomePhabricator

Review unsubscribe/unwatch icon
Closed, ResolvedPublic

Description

We need an icon to convey the idea of stop watching something (or unsubscribe). The proposed icon is provided below with some examples:

I'm looking for feedback about:

  • How well it works visually.
  • How well it fits in the general icon guidelines.

Context

As described in T132975, the icon is intended to communicate an action of stoping watching an item (a Flow post or page).

This is not intended to replace the watchlist controls on wiki pages or other uses representing status. For those cases, unwatched state is represented by an empty star which gets filled once the item is watched, and the actions are implicit but clear. Conversely, the proposed icon is intended to where a more explicit representation of the unwatched action is needed since it refers to another element for which we are not representing the status.

In the original version (view mockup below) it seems it was not as easy to recognise as intended:

I also had one quibble: I worked out that the icon is a star with a slash through it, which makes sense. But it didn't read as that for me at first. I showed it to a few others who had similar experience. @Pginer-WMF, I'm not sure how to advise you on the solution, but would it be possible to have another go at that. (I think the issue, for me, has to do with that little stub of the star-point on the lower right. My eye gets tricked into reading it as a short line running parallel to the slash, rather than seeing it as what it is.)

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 9 2016, 12:42 PM
Danny_B added a subscriber: Danny_B.

Is this intended for Flow only?

Is this intended for Flow only?

As the immediate step, the action is planed for Flow-related notifications (T132975), but the action can be provided for other kinds of notifications that need similar (un)subscription mechanisms.

This falls under a more general area of "volume control", where users can have more control on the kind of notifications they receive. More details about this in T115264. This is a complex area, and the case of unwatching Flow topics/boards is a simple initial step to learn more about this area.

Let me rephrase to clarify - is this icon supposed to be used for the regular unwatch icon in tab (next to history tab) as well?

Let me rephrase to clarify - is this icon supposed to be used for the regular unwatch icon in tab (next to history tab) as well?

No. The current approach for the tab makes sense to be based on status. Since communicating the status is the main goal, and the associated actions can be understood implicitly:

  • The neutral state (not watching) announces that you can watch the page with the star silhouette.
  • Once the user is watching a page it communicates that status and the action to undo it is implicit (acting on the star again).

The reference I made in the description about this was to explain that we needed a specific icon for the action (in the context of an action, both the filled or outline star would be hard to identify as unwatch), but it was not intended to suggest replacing the status-based approach where it makes sense.

Hey @Pginer-WMF – as small side-note: We're in discussion about direction of cross-out lines in icons and current best solution from my view would be bottom-left to top-right, as laid out in T133076#2219075

Thanks. I was not proposing that, I just wanted to clarify the area of usage of such icon, since it was not clear which areas it would involve due to lack of appropriate tags and unambiguous description...

Thanks. I was not proposing that, I just wanted to clarify the area of usage of such icon, since it was not clear which areas it would involve due to lack of appropriate tags and unambiguous description...

As I was writing my reply, I noticed the original description was not very helpful. I'll add more details to the description in order to provide more clarity. Thanks for pointing at this, @Danny_B.

Hey @Pginer-WMF – as small side-note: We're in discussion about direction of cross-out lines in icons and current best solution from my view would be bottom-left to top-right, as laid out in T133076#2219075

Pginer-WMF updated the task description. (Show Details)May 10 2016, 10:28 AM
Pginer-WMF updated the task description. (Show Details)May 10 2016, 10:33 AM

Hey @Pginer-WMF – as small side-note: We're in discussion about direction of cross-out lines in icons and current best solution from my view would be bottom-left to top-right, as laid out in T133076#2219075

I updated the icon and examples to align with this. Thanks for pointing to it, @Volker_E

@Pginer-WMF The decision was taken at T133076: Cross-out lines in OOUI's MediaWiki theme icons are pointing to different directions.
Also from the task description I wonder if the action isn't better described with a crossed-out eye icon?https://github.com/wikimedia/WikiFont/blob/master/svgs/uniE007%20-%20eye.svg
The star, in browser context often used as favorite action, in MediaWiki context redefined as “watch” action which is a hybrid of favorite/bookmark and watch seems weird to me.
But I guess we can't easily change the historic and IMHO mislead icon choice.
Unstar as unwatch.

The star, in browser context often used as favorite action, in MediaWiki context redefined as “watch” action which is a hybrid of favorite/bookmark and watch seems weird to me.

The way to "subscribe" to boards is to watch the page where the board is. Similarly topics have a star icon to watch them. The action is equivalent of clicking back that star icon.
I don't have a preference on the metaphor used but I think it is better to keep it consistent across these different places.

Volker_E added a comment.EditedJul 21 2016, 1:54 PM

As laid out at https://phabricator.wikimedia.org/T132975#2433018

we can start by using the empty star icon for this action (the icon named "Star" in the repo).
If we find confusion in practice (e.g., empty star triggering different actions in different contexts), we can consider using a specific icon describing the action

Therefore closing this for now, might be re-opened in future when above situation is given.

Volker_E closed this task as Resolved.Jul 21 2016, 1:55 PM

As laid out at https://phabricator.wikimedia.org/T132975#2433018

we can start by using the empty star icon for this action (the icon named "Star" in the repo).
If we find confusion in practice (e.g., empty star triggering different actions in different contexts), we can consider using a specific icon describing the action

As I said, I don't think an empty star should be used for unwatch, since that is indeed confusing. See my comment there.

RHo added a subscriber: RHo.Jul 22 2016, 9:13 AM

I've just commented on that ticket T132975: Allow unwatching a Flow topic/board from a notification about that topic/board with some additional context for the decision.