Page MenuHomePhabricator

{{REVISION*}} magic words should not display usernames and timestamps for null edits
Closed, ResolvedPublic

Description

Example https://commons.wikimedia.org/wiki/File_talk:I_Can_Help_Me_-No,_film_still_-1,_%C2%A9Agnes_Janich,_2009.jpg (now deleted; had {{subst:ops}}

It has a template that displays the last editor and the timestamp of that edit, along side a link to &diff=cur.

However, {{REVISIONUSER}} causes a bot's null edit be displayed as the last edit, when in fact it is not an edit which are recorded in the edit history, thereby not an actual new "revision", which these magicwords are for.

I had to do a manual purge to make it display the last 'real' editors username instead

Details

Related Gerrit Patches:

Event Timeline

Josve05a created this task.May 13 2016, 7:39 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 13 2016, 7:39 PM
Josve05a updated the task description. (Show Details)May 13 2016, 7:40 PM

Seems like a dupe to me, however, the other task mentions it has been fixed, therefore this would have to be a regression then.

Whoever investigates that, please add Regression if relevant, thanks.

Krinkle removed a subscriber: Krinkle.May 16 2016, 6:37 PM
Danny_B renamed this task from {{REVISIONID}} and related magic words should not display usernames and timestamps for null edits to {{REVISION*}} magic words should not display usernames and timestamps for null edits.May 17 2016, 9:41 AM

Change 293683 had a related patch set uploaded (by Aaron Schulz):
Improvements to {{REVISIONUSER}} handling

https://gerrit.wikimedia.org/r/293683

Change 293683 merged by jenkins-bot:
Improvements to {{REVISIONUSER}} handling

https://gerrit.wikimedia.org/r/293683

Change 294369 had a related patch set uploaded (by Aaron Schulz):
Improvements to {{REVISIONUSER}} handling

https://gerrit.wikimedia.org/r/294369

Change 294369 merged by jenkins-bot:
Improvements to {{REVISIONUSER}} handling

https://gerrit.wikimedia.org/r/294369

Josve05a added a subscriber: aaron.Oct 5 2016, 12:50 AM

@aaron Can you check if your patch did what it was supposed to do? :)

Only {{REVISIONUSER}} and {{REVISIONID}} are fixed. The rest no.

Change 336102 had a related patch set uploaded (by Zhuyifei1999):
WikiPage::doModify: Reuse old revision while null-editing

https://gerrit.wikimedia.org/r/336102

@zhuyifei1999 The change is now marked as "Cannot Merge". Could anybody update and merge it? @aaron, @ori?

In ruwiki, we're experiencing troubles because of this bug. One of our bots does a good service for us by automatically performing a null edit to a limited number of pages to update them along with their categories, and by that categories the bot tries to figure what pages he should visit next time. But because of this bug the bot always thinks that the page was updated recently, and comes back to it, despite the fact that he was the last editor of this page by doing null edit.

@Jack_who_built_the_house The patch above should, theoretically, handle it. Obviously, nobody does the code review :(

So, what now? Shows "Cannot Merge" again.

@zhuyifei1999 This is a very desired change, is there anything that can be done?

@zhuyifei1999 This is very desired change, is there anything that can be done?

Ask someone to review it.

I can only ping again those who did the previous review: @Legoktm, @aaron, @ori.

@zhuyifei1999 So, "Cannot Merge" isn't a problem, right? Sorry, I'm new to that interface.

aaron added a comment.EditedOct 24 2017, 1:54 AM

That "cannot merge" message is mostly useless and overly-technical in a Gerrit specific way (e.g. you can't "submit" without "+2", which is obvious anyway). Just look for "merge conflict" on the changeset page or where the patch shows up in listings, since that actually matters and is common.

Change 336102 merged by jenkins-bot:
[mediawiki/core@master] WikiPage::doModify: Reuse old revision while null-editing

https://gerrit.wikimedia.org/r/336102

zhuyifei1999 closed this task as Resolved.Nov 18 2017, 4:28 AM

https://commons.wikimedia.org/wiki/User:Zhuyifei1999/sandbox/2 {{REVISIONTIMESTAMP}} now stays 20171118042628 despite two null-edit attempts. If my tests are wrong or there is still something else to be fixed please reopen.