Page MenuHomePhabricator

Cannot log out on beta
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. go to http://en.wikipedia.beta.wmflabs.org/
  2. register new account
  3. log out

CentralAuth will immediately log you back in.

Could not reproduce with a non-new account.

Event Timeline

Tgr created this task.May 17 2016, 4:52 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 17 2016, 4:52 PM
Tgr triaged this task as Unbreak Now! priority.May 17 2016, 4:52 PM
Restricted Application added subscribers: Luke081515, TerraCodes, Urbanecm. · View Herald TranscriptMay 17 2016, 4:52 PM
Anomie added a subscriber: Anomie.May 17 2016, 5:18 PM

Seems very unlikely, since it shouldn't be coming into play at all here. CentralAuth only sets the flag in CentralAuthTokenSessionProvider, which isn't being used here.

Change 289246 had a related patch set uploaded (by Gergő Tisza):
Revert "Avoid DBPerformance log warnings in onUserLogout()"

https://gerrit.wikimedia.org/r/289246

Change 289246 abandoned by Gergő Tisza:
Revert "Avoid DBPerformance log warnings in onUserLogout()"

Reason:
anomie found a fix.

https://gerrit.wikimedia.org/r/289246

Change 289248 had a related patch set uploaded (by Gergő Tisza):
Fix central logout

https://gerrit.wikimedia.org/r/289248

Change 289248 merged by jenkins-bot:
Fix central logout

https://gerrit.wikimedia.org/r/289248

Anomie closed this task as Resolved.May 17 2016, 6:46 PM
Anomie claimed this task.

Change 289431 had a related patch set uploaded (by Gergő Tisza):
Fix central logout

https://gerrit.wikimedia.org/r/289431

Change 289431 merged by Thcipriani:
Fix central logout

https://gerrit.wikimedia.org/r/289431

Change 299880 had a related patch set uploaded (by Gergő Tisza):
Fix central logout

https://gerrit.wikimedia.org/r/299880

Change 299880 merged by jenkins-bot:
Fix central logout

https://gerrit.wikimedia.org/r/299880

Restricted Application added a subscriber: Jay8g. · View Herald TranscriptDec 15 2016, 4:16 PM