Page MenuHomePhabricator

PHP Warning: require_once(/home/randomwi/public_html/en/vendor/composer/autoload_static.php): failed to open stream:
Closed, ResolvedPublic

Description

Steps to reproduce

  • Download mediawiki core 1.28 wmf 2
  • Download mediawiki/vendor 1.28 wmf 2.

And install it.

Actual results

  • It errors out with

[18-May-2016 12:36:08 UTC] PHP Warning: require_once(/home/randomwi/public_html/en/vendor/composer/autoload_static.php): failed to open stream: No such file or directory in /home/randomwi/public_html/en/vendor/composer/autoload_real.php on line 32
[18-May-2016 12:36:08 UTC] PHP Fatal error: require_once(): Failed opening required '/home/randomwi/public_html/en/vendor/composer/autoload_static.php' (include_path='/home/randomwi/public_html/en/vendor/pear/pear_exception:/home/randomwi/public_html/en/vendor/pear/console_getopt:/home/randomwi/public_html/en/vendor/pear/pear-core-minimal/src:/home/randomwi/public_html/en/vendor/pear/mail_mime:/home/randomwi/public_html/en/vendor/pear/mail_mime-decode:/home/randomwi/public_html/en/vendor/pear/net_socket:/home/randomwi/public_html/en/vendor/pear/net_smtp:/home/randomwi/public_html/en/vendor/pear/mail:.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/randomwi/public_html/en/vendor/composer/autoload_real.php on line 32

Expected results

  • It should not error out and my wiki should load.

This was caused by https://github.com/wikimedia/mediawiki-vendor/commit/4bd8ba35627e7d70036de02eeec5e52ba64b9250

It didn't add the autoload_static file. We should not add the file due to linting errors we found on ci.

Event Timeline

Paladox created this task.May 18 2016, 3:19 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 18 2016, 3:19 PM

Can this be set as high since it breaks php 5.6 or higher due to autoload_static missing. We need to not use that file due to linting issues.

bd808 added a subscriber: bd808.May 18 2016, 3:36 PM

See T135161: Composer v1.1.0 generated vendor dirs will fail lint by PHP <5.6 for an explanation of why we can't use Composer 1.1.x to generate the frozen mediawiki/vendor.git repo at the moment.

Change 289432 had a related patch set uploaded (by Paladox):
Fix composer erroring out on php5.6

https://gerrit.wikimedia.org/r/289432

Change 289434 had a related patch set uploaded (by BryanDavis):
Rebuild with composer 1.0.0 for PHP >=5.6 users

https://gerrit.wikimedia.org/r/289434

@bd808 yep upstream in composer have said no to adding an extra flag for disabling this. So users using composer 1.1.0 will generate it if they use php 5.6.

See https://github.com/composer/composer/issues/5354

Change 289432 abandoned by Paladox:
Fix composer erroring out on php5.6

Reason:
Using https://gerrit.wikimedia.org/r/#/c/289434/ instead.

https://gerrit.wikimedia.org/r/289432

Change 289434 merged by jenkins-bot:
Rebuild with composer 1.0.0 for PHP >=5.6 users

https://gerrit.wikimedia.org/r/289434

Paladox closed this task as Resolved.May 18 2016, 7:46 PM
Paladox assigned this task to bd808.
Restricted Application added a project: User-bd808. · View Herald TranscriptMay 18 2016, 7:46 PM

Change 289541 had a related patch set uploaded (by Paladox):
Rebuild with composer 1.0.0 for PHP >=5.6 users

https://gerrit.wikimedia.org/r/289541

bd808 moved this task from To Do to Archive on the User-bd808 board.May 20 2016, 11:43 PM

Change 289541 abandoned by Reedy:
Rebuild with composer 1.0.0 for PHP >=5.6 users

https://gerrit.wikimedia.org/r/289541