Page MenuHomePhabricator

GSoC: Pywikibot-Thanks | Meeting 9 | 24th June
Closed, ResolvedPublic

Description

| Friday, 24th June 2016 - 15:30 UTC
| jayvdb, legoktm, darthbhyrava

Skype
Description: Final Weekly Meeting before the Mid-Term Evaluation


Agenda:

  • Review patch for T135409 : 294901.
  • Review patch for T135411: 295132.
  • Requirements for passing Mid-Term Evaluations:
    • Patches pass with +2 from jenkins.
    • Submitted the Evaluation Form.
    • Updating Weekly Reports - T133667.
    • Changes pushed to local GitHub repository.
    • Blog posts up-to-date here.

Changes made since last meet :

Subtask I
  • Use the Revision class instead of a recursive function to get revision details in thanks.py.
  • Remove the hack and let User.thanks_enabled do the job in thanks_tests.py.
  • Improve the assertion in unit test scripts to make it more precise and meaningful.
  • Shift to variable revid consistently throughout.
  • Add source as a user customisable parameter to def get_revision() in site.py
  • Shift the above method in site.py next to the other revision methods.
  • Shift thanks.py to maintenance folder.
  • Adhere to coding linting rules.
  • Remove u"" since we're using unicode literals.
  • thank_rev should take APISite as a parameter.
  • If user.thanks_enabled=False, then what?
  • If user doesn't specify arguments, then what?
  • Use self.assertRaises to check for exceptions thrown for bad data. Account for as many as possible.
  • Change name of unit test class to a non-abbreviated one.
  • Improve implementation of getting Site object.
  • Add tests for new site.py method. What class, what to assert?
  • Add write=True to thanks_tests as per tests/README Tests fail, ask me to add PYWIKIBOT2_TEST_WRITE=1
  • Make direct calls to page.py and site.py for unit test. On hold - what are we testing, then?
Subtask II
  • Look into and document all errors caused by sort_by='updated' param in flow_thanks_tests.py.
  • Get a suitable workaround for the bug in flow_thanks_tests.py, and document the bug.
    • Sorting by 'newest' and slicing the generator.
  • Improve the assertion in unit test scripts to make it more precise and meaningful.
  • Use ordinary slice instead of islice()
    • Ordinary slice cannot be used for iterators and generators in python.
  • Shift flow_thanks.py to maintenance folder.
  • Adhere to coding linting rules.
  • Remove u"" since we're using unicode literals.
  • thank_flowpost should take APISite as a parameter.
  • If user.thanks_enabled=False, then what?
    • Not implementing thanks_enabled in this task now.
    • TODO later.
  • Improve implementation of getting Site object.
  • If user doesn't specify arguments, then what?
    • Error raised.
  • Remove the list post_ids[] and rename it appropriately.
  • Use self.assertRaises to check for exceptions thrown for bad data. Account for as many as possible.
  • Add tests for new site.py method.
  • MVP for the mid-term evaluation:
    • The MVP would be subtasks 1 and 2 implemented, reviewed and wrapped up.
    • The code for subtasks 1 and 2 must all be merged to pass the mid-term evaluation.
    • If the code is not completely merged, then the code may still be considered if all of it has been submitted in Gerrit with a +2 from jenkins-bot.
    • There must be a branch on my GitHub fork which has all the aforementioned patches integrated and all the tests passing.
  • Apart from the technical deliverables, I would also be having weekly reports for progress along with a weekly blog post, and regularly update the documentation as required.

Minutes of the Meeting:

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 23 2016, 8:09 PM

@jayvdb cannot make it on the 24th. He would be available on Sunday, the 26th, instead.
@Legoktm can you make it to the meeting today, or would you rather have it on the 26th?

darthbhyrava updated the task description. (Show Details)Jun 24 2016, 3:32 PM
darthbhyrava updated the task description. (Show Details)Jun 24 2016, 6:24 PM
darthbhyrava updated the task description. (Show Details)Jun 26 2016, 1:14 PM

This needs to be closed.

srishakatux closed this task as Resolved.May 1 2017, 8:25 PM