Page MenuHomePhabricator

Page diff test failing
Closed, ResolvedPublic1 Story Points

Description

One of our selenium tests has been failing in Firefox for the last two builds: https://integration.wikimedia.org/ci/job/selenium-MobileFrontend/139/testReport/

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 30 2016, 6:34 PM

I'm a bit confused by this failure as it failed in both Chrome and Firefox in 138 but only fails in Firefox in 139...

dr0ptp4kt triaged this task as High priority.Aug 31 2016, 3:10 PM
dr0ptp4kt moved this task from Incoming to Needs Prioritization on the Readers-Web-Backlog board.
phuedx claimed this task.Sep 6 2016, 8:38 AM

I'm going to see if I can reproduce this locally…

I'm a bit confused by this failure as it failed in both Chrome and Firefox in 138 but only fails in Firefox in 139...

… and in #148, it only fails in Chrome.

Change 308956 had a related patch set uploaded (by Phuedx):
Tests: Test edit succeeded before editing again

https://gerrit.wikimedia.org/r/308956

This is blocked on T144912.

jhobs changed the task status from Open to Stalled.Sep 12 2016, 4:27 PM

Change 308956 abandoned by Phuedx:
Tests: Test edit succeeded before editing again

Reason:
This should be resurrected if these tests start failing intermittently again.

https://gerrit.wikimedia.org/r/308956

phuedx closed this task as Invalid.Dec 7 2016, 7:27 AM

The tests haven't failed for quite a while…

phuedx reopened this task as Open.Mar 8 2017, 4:09 PM
phuedx removed phuedx as the assignee of this task.

This test has failed intermittently during the last couple of builds. The most recent build failure caused by the test is #351.

It's failing due to edit conflicts. This could happen if both Firefox and Chrome browser tests run at the same time.

Change 345425 had a related patch set uploaded (by Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Diff test should not fail when parallel browser tests

https://gerrit.wikimedia.org/r/345425

rEMFR22a6bf68e5a3: Diff test should not fail when parallel browser tests causes the build to fail as there's a problem with the definition of the new step.

phuedx assigned this task to Jdlrobson.Mar 29 2017, 10:39 PM

Change 345425 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Diff test should not fail when parallel browser tests

https://gerrit.wikimedia.org/r/345425

phuedx closed this task as Resolved.Mar 29 2017, 11:05 PM
phuedx moved this task from Needs Code Review to Ready for Signoff on the Reading-Web-Sprint-94 board.

This LGTM! Let's close this task for now and re-open it if we see the scenario failing repeatedly again.

Jdlrobson set the point value for this task to 1.Mar 30 2017, 9:11 PM