Page MenuHomePhabricator

Exception in module-execute in module skins.minerva.scripts: MobileFrontend Module not found: skins.minerva.scripts.top/mainMenu
Closed, ResolvedPublic2 Story Points

Description

The following error message appeared today in UploadWizard's client-side exception log:

Exception in module-execute in module skins.minerva.scripts:  MobileFrontend Module not found: skins.minerva.scripts.top/mainMenu

It doesn't seem specific to UploadWizard, I managed to reproduce it once when browsing Commons in the mobile version.

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : masterBe explicit with dependency

Event Timeline

matmarex created this task.Sep 13 2016, 7:57 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 13 2016, 7:57 PM

The earliest instance of this issue is on 20160907214111.

ovasileva triaged this task as High priority.Sep 21 2016, 4:41 PM
ovasileva moved this task from Incoming to Triaged but Future on the Readers-Web-Backlog board.
ovasileva moved this task from Triaged but Future to 2016-17 Q2 on the Readers-Web-Backlog board.
ovasileva lowered the priority of this task from High to Medium.Sep 26 2016, 4:22 PM
phuedx added a subscriber: phuedx.Sep 26 2016, 4:25 PM

@matmarex: Could you provide a little more information? Which browser were you using? Was there a specific page on Commons that you were looking at?

MBinder_WMF set the point value for this task to 2.Sep 26 2016, 4:25 PM
MBinder_WMF moved this task from 2016-17 Q2 to Needs Prioritization on the Readers-Web-Backlog board.

@phuedx You can see the user-agents logged by running the following query on stat1003 (46 result rows):

use log;
select * from UploadWizardExceptionFlowEvent_11772722
where event_message like '%skins.minerva.scripts.top/mainMenu%';

These will all be from Special:UploadWizard, although I saw it on some other page too (don't remember now, sorry). Of course we don't log errors on pages other than Special:UploadWizard in UploadWizard error logs :)

But actually, whatever this was, it seems to be fixed… the latest timestamp in the logs is 20160920144105. The timing seems to match T146099, perhaps it is somehow related?

matmarex closed this task as Resolved.Sep 26 2016, 5:08 PM
Jdlrobson reopened this task as Open.Sep 26 2016, 11:58 PM
Jdlrobson added a subscriber: Jdlrobson.

I ran into this locally and it does look possible when you remember that localStorage can be used for modules... better to be safe then sorry:

Change 312946 had a related patch set uploaded (by Jdlrobson):
Be explicit with dependency

https://gerrit.wikimedia.org/r/312946

BTW the current version of the resource-modules linter, although imperfect, is catching some weirdness with the dependencies here (full log):

Error: Dependency problems in file: resources/skins.minerva.scripts/preInit.js:
  ...
  Required skins.minerva.scripts.top/mainMenu defined in file resources/skins.minerva.scripts.top/init.js not found in any ResourceModules

There's more work to be done but I'm hopeful this kind of errors won't slip into master again once we've polished it.

Change 312946 merged by jenkins-bot:
Be explicit with dependency

https://gerrit.wikimedia.org/r/312946

@Jdlrobson - noticed you took this out of the sprint - isn't it done?

phuedx reassigned this task from Jdlrobson to Jhernandez.Sep 29 2016, 8:58 AM
Krinkle removed a subscriber: Krinkle.Sep 29 2016, 7:00 PM
Jhernandez closed this task as Resolved.Oct 3 2016, 11:09 AM