Page MenuHomePhabricator

NWE: Can't edit transcluded sections
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce:

  1. Go to https://de.wikipedia.beta.wmflabs.org/wiki/Transkludierte_Testseite (or any other page that transcludes a template/page with sections).
  2. Edit a section in NWE.

Actual result:
You edit the whole source of Transkludierte_Testseite (which is just the transclusion).

Expected result:
Like in OWE, you should edit the respective section of "Testseite" instead, note that the edit URL has that page as title and a section starting with "T-".

Event Timeline

Schnark created this task.Dec 14 2016, 8:27 AM
Restricted Application added a project: VisualEditor. · View Herald TranscriptDec 14 2016, 8:27 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Looks like the API doesn't support section=T-1 :/

Esanders added a subscriber: Catrope.

Ignore that - I've misread the URL - we're going to have to do a redirect...

Change 327398 had a related patch set uploaded (by Esanders):
Allow 'T-' prefixed sections, and redirect if section link title isn't current page

https://gerrit.wikimedia.org/r/327398

Jdforrester-WMF triaged this task as Normal priority.
Jdforrester-WMF set the point value for this task to 1.
Jdforrester-WMF moved this task from To Triage to TR1: Releases on the VisualEditor board.

Change 327398 merged by jenkins-bot:
Allow 'T-' prefixed sections, and redirect if section link title isn't current page

https://gerrit.wikimedia.org/r/327398

Jdforrester-WMF closed this task as Resolved.Jan 4 2017, 10:43 PM
Jdforrester-WMF removed a project: Patch-For-Review.
Dvorapa added a subscriber: Dvorapa.Jan 5 2017, 3:38 AM