Page MenuHomePhabricator

Clicking "New section" does nothing while editing in New Wikitext Editor
Closed, ResolvedPublic1 Estimated Story Points

Description

Clicking "New section" link at the top of the screen does nothing while editing a talk page using NWE. With the regular wiki syntax editor, it opens a new section, and it should do the same in the new editor.

Opening it in a new tab, for example with middle-click, does the right thing in both new and regular editors.

Event Timeline

Amire80 created this task.Dec 17 2016, 1:58 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptDec 17 2016, 1:58 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

If you start in "Add topic", then clicking "Edit source" doesn't switch you to editing the whole page.

Okay, I have no idea what my previous comment is supposed to mean, or why it's here instead of in some other (presumably more relevant) task. If anyone can enlighten me as to what I meant, please do so.

But I want to add: This (adding new sections to pages) is working for me now, and it even comes with a very nice (though un-editable) edit summary.

Okay, I have no idea what my previous comment is supposed to mean, or why it's here instead of in some other (presumably more relevant) task. If anyone can enlighten me as to what I meant, please do so.

It's this kind of comment that makes me want to have a per-comment "Like" button in Phabricator :)

More on point, I exactly what you meant understand: you wrote instructions to reproduce a bug, and I managed to reproduce it exactly as you wrote. I am not going to report it separately, however, because I've got a hunch that its cause is the same as the cause of this one.

But I want to add: This (adding new sections to pages) is working for me now, and it even comes with a very nice (though un-editable) edit summary.

Hmm, it doesn't work for me. I just tried it. Go to https://en.wikipedia.org/wiki/Talk:ASCII?veaction=editsource , click "New section", and nothing happens.

Elitre added a subscriber: Elitre.Feb 6 2017, 10:02 AM

"New section" at Talk:ASCII works for me, in Safari 10, if I either click your link or go to the page and open the new section as a new tab behind the current one (Command-click). But if I just go to the page and click the link (plain click), then it doesn't work. Nothing happens.

Jdforrester-WMF closed this task as Resolved.Feb 7 2017, 8:24 PM
Jdforrester-WMF claimed this task.
Jdforrester-WMF triaged this task as Medium priority.
Jdforrester-WMF set the point value for this task to 1.
Jdforrester-WMF moved this task from To Triage to TR1: Releases on the VisualEditor board.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

This appears to be working now (but T157104 is very much not working).