Page MenuHomePhabricator

RC - filters group names and descriptions should be searchable
Closed, ResolvedPublic

Description

As follow up for T149435: Build user interface for the Filter Search Bar

When searching for filters' names, the match will be found only in the filter names, not in descriptions or filter group names.
e.g. '10 edits' will not find anything; 'edits' will be match with filter names containing that string in their names.

Making filters group names and descriptions searchable may improve the usability(and discoverability) of the filters and RC page overall.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 25 2017, 1:59 AM

From T149435: Build user interface for the Filter Search Bar

The search looks first for menu items that start with the query text; if there are no results, it falls back to match filters containing the query string anywhere in their name or description.

Change 335243 had a related patch set uploaded (by Sbisson):
Expand RC filters search to include desc and group title

https://gerrit.wikimedia.org/r/335243

Change 335243 merged by jenkins-bot:
Expand RC filters search to include desc and group title

https://gerrit.wikimedia.org/r/335243

@SBisson
When checking in betalabs, there is

  • no suggestions display for any input
  • on each typed character - the Consoles fires the following error: Uncaught TypeError: this.model.getName is not a function(…)
mw.rcfilters.ui.FilterGroupWidget.getName
mw.rcfilters.ui.FiltersListWidget.filter
mw.rcfilters.ui.FilterWrapperWidget.onTextInputChange
oo.EventEmitter.emit
OO.ui.InputWidget.setValue

Change 336780 had a related patch set uploaded (by Sbisson):
RC filters: Let the group widget know its own name

https://gerrit.wikimedia.org/r/336780

[...]

Uncaught TypeError: this.model.getName is not a function(…)

This is caused by T156533. It changed the way filters are grouped but did not test the interaction with the search feature. The patch above should fix it.

https://gerrit.wikimedia.org/r/#/c/335951/ fixes this too, but that's a larger change, so I'll merge yours now and fix it in the rebase later.

Change 336780 merged by jenkins-bot:
RC filters: Let the group widget know its own name

https://gerrit.wikimedia.org/r/336780

Checked in betalabs - RC filters group names and descriptions are searchable.

Note: It's interesting that the search for 'edits' returns only 'Edits by others' and not even 'Your own edits' which is in the same group.

QA recommendation: Resolve.

jmatazzoni closed this task as Resolved.Feb 17 2017, 7:30 PM