Page MenuHomePhabricator

Issues with template parameters
Open, Stalled, NormalPublic1 Story Points

Description

(Apologies for the potentially unhelpful title)
From mw.org:

"I discovered two issues with inserting template:

  1. Previewing an edit which inserts a template (by copy pasting in the template code) fails to pick up any of the parameter values (i.e. I get shown a bunch of triple-{)
  2. Doing a roundtrip via visual editor kills every single line-break and extra whitespace in the original text. But magically this allows the preview to pick up on the parameters

[...] IIRC it was Wmse:Template:Resemall (on wmse chapter wiki)

[...] I created a video showing both the issue with failing parameters, the whitespace mangling when going to VE and then the recovery of the parameters when going back to NWT.
The text which I pasted in was copied from "classic" wikitext. If copying the pre-tagged example from the template documentation NWT does not handle the linebreaks correctly BUT can detect the parameters."

(This said, I wonder if T156498: When pasting text, don't translate multiple normal spaces into multiple non-breaking spaces is related.)

Event Timeline

Elitre created this task.Jan 27 2017, 5:47 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptJan 27 2017, 5:47 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Jdforrester-WMF changed the task status from Open to Stalled.Feb 14 2017, 8:28 PM
Jdforrester-WMF triaged this task as Normal priority.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Yes, I think T156498: When pasting text, don't translate multiple normal spaces into multiple non-breaking spaces is definitely the first one – could that be re-tested?

The second one sounds like a different thing which we can re-purpose this task for if the first bit is solved, though!

Jdforrester-WMF set the point value for this task to 1.

Ping on this – if we could find out if issue 2 ("Doing a roundtrip via visual editor kills every single line-break and extra whitespace in the original text") is still happening that'd be great.

ssastry added a subscriber: ssastry.

Not sure if Parsoid is involved here. But, please re-add Parsoid tag if a Parsoid fix is needed.

Issue 2 is perhaps related to T179259 and T213922?

I suspect it's not related to T213922, that problems seems new and this one occurred two years ago. It's also unlikely to be T179259, as I believe the Parsoid behavior described there was also introduced after this task was filed.