Page MenuHomePhabricator

Large amount of "DatabaseMysqlBase::lock failed to acquire lock 'wikidatawiki-activeusers'" timeout-errors on wikidata since 2017-01-30 8:05 UTC
Closed, ResolvedPublic

Description

I am not sure if this is wikidata or deployment related: https://logstash.wikimedia.org/goto/29bb2ebcf0ccd9e90e4f7773fdc666dd

They are caused by a job, but no deployments or external causes found at the time. They look like this:

{
  "_index": "logstash-2017.01.30",
  "_type": "mediawiki",
  "_id": "AVnvSXzq3-sTQj-LhJL3",
  "_score": null,
  "_source": {
    "message": "DatabaseMysqlBase::lock failed to acquire lock 'wikidatawiki-activeusers'\n",
    "@version": 1,
    "@timestamp": "2017-01-30T12:11:27.000Z",
    "type": "mediawiki",
    "host": "mw1166",
    "level": "WARNING",
    "tags": [
      "syslog",
      "es",
      "es"
    ],
    "channel": "DBQuery",
    "normalized_message": "DatabaseMysqlBase::lock failed to acquire lock 'wikidatawiki-activeusers'\n",
    "url": "/rpc/RunJobs.php?wiki=wikidatawiki&type=recentChangesUpdate&maxtime=60&maxmem=300M",
    "ip": "127.0.0.1",
    "http_method": "POST",
    "server": "127.0.0.1",
    "referrer": null,
    "wiki": "wikidatawiki",
    "mwversion": "1.29.0-wmf.9",
    "reqId": "WI8tbQpAID4AAByFT3UAAABY"
  },
  "fields": {
    "@timestamp": [
      1485778287000
    ]
  },
  "sort": [
    1485778287000
  ]
}

Event Timeline

jcrespo created this task.Jan 30 2017, 3:28 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 30 2017, 3:28 PM

Change 335203 had a related patch set uploaded (by Hoo man):
Make RecentChangesUpdateJob::updateActiveUsers more robust

https://gerrit.wikimedia.org/r/335203

hoo claimed this task.Jan 31 2017, 9:49 AM
hoo added a subscriber: hoo.

This is probably due to the large amounts of edits on Wikidata.
Taking.

This is probably due to the large amounts of edits on Wikidata.
Taking.

Thank you!

Change 335203 merged by jenkins-bot:
Make RecentChangesUpdateJob::updateActiveUsers more robust

https://gerrit.wikimedia.org/r/335203

hoo moved this task from Review to Done on the Wikidata-Former-Sprint-Board board.Feb 16 2017, 6:19 PM
hoo removed a project: Patch-For-Review.
Lydia_Pintscher closed this task as Resolved.Mar 7 2017, 3:43 PM
Lydia_Pintscher added a subscriber: Lydia_Pintscher.

Resolving as it seems this is all done.