RevisionSlider tooltip position broken on RTL languages
Closed, ResolvedPublic

Description

See screenshot. The issue was introduced with OOjs UI v0.19.2 but seems to be fixed in v0.19.4. The later is not deployed on production yet.

See as well: https://www.mediawiki.org/wiki/Topic:Tlyesrmx98oz50ce

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 2 2017, 10:26 AM

When fixing this - e.g. by deploying v0.19.4 be aware, that this version will introduce a new issue: T159434

More testing with v0.19.4 brought up another problem with RTL and popups:

The tooltips are not completly out of place but instead of shown centered under the revision hovered they show at the right end. See screenshot below, the mouse hovering over the red circled revision.

Change 340779 had a related patch set uploaded (by WMDE-Fisch):
[mediawiki/extensions/RevisionSlider] Quick fix for misplaced tooltips on RTL wikis

https://gerrit.wikimedia.org/r/340779

WMDE-Fisch claimed this task.

Change 340794 had a related patch set uploaded (by Addshore; owner: WMDE-Fisch):
[mediawiki/extensions/RevisionSlider] Quick fix for misplaced tooltips on RTL wikis

https://gerrit.wikimedia.org/r/340794

WMDE-Fisch moved this task from Incoming to Revision Slider on the TCB-Team board.Mar 3 2017, 12:00 PM

Change 340981 had a related patch set uploaded (by wmde-fisch):
[mediawiki/extensions/RevisionSlider] Refactor usage of OOjs UI tooltips

https://gerrit.wikimedia.org/r/340981

https://gerrit.wikimedia.org/r/340981 fixes the tooltips for the current master and v0.19.4. Now they are used as intended and hopefully more stable when it comes to changes.

Change 340794 merged by jenkins-bot:
[mediawiki/extensions/RevisionSlider] Quick fix for misplaced tooltips on RTL wikis

https://gerrit.wikimedia.org/r/340794

Change 340779 merged by jenkins-bot:
[mediawiki/extensions/RevisionSlider] Quick fix for misplaced tooltips on RTL wikis

https://gerrit.wikimedia.org/r/340779

Mentioned in SAL (#wikimedia-operations) [2017-03-03T18:43:06Z] <addshore@tin> Synchronized php-1.29.0-wmf.14/extensions/RevisionSlider/modules/ext.RevisionSlider.css: T159428 [[gerrit:340794|Quick fix for misplaced tooltips on RTL wikis]] (duration: 00m 42s)

Deployed.
It looks like this is only a partial fix, the tooltip is still miss-aligned, but at least it can now be seen on RTL wikis.

Sorry, @Addshore, it can't.

@IKhitron it seems to be working for me!

Could you attach a screenshot of how it appears for you?
Please make sure the CSS is not cached in your browser!

IKhitron added a comment.EditedMar 3 2017, 6:52 PM

It works now. Maybe it needed some time. I did then Ctrl-F5 and purge, didn't help, but now it's just fixed without changing something else. Thank you!

Addshore triaged this task as High priority.

Change 340981 merged by jenkins-bot:
[mediawiki/extensions/RevisionSlider] Refactor usage of OOjs UI tooltips

https://gerrit.wikimedia.org/r/340981

It looks like this is only a partial fix, the tooltip is still miss-aligned, but at least it can now be seen on RTL wikis.

When https://gerrit.wikimedia.org/r/340981 is deployed this week the tooltip should be aligned completely fine again.

Tobi_WMDE_SW closed this task as Resolved.Mar 10 2017, 2:24 PM