Page MenuHomePhabricator

Hovering over any link, no 'title' attribute of <a> tag is displayed in Russian Wikipedia
Closed, ResolvedPublic2 Story Points

Description

Regardless of whether Hovercards is on or off, the tooltip doesn't appear when you hover over a link after the page is loaded. The 'title' attribute of <a> tag disappears in that moment. I think, Hovercards ext does it.

Browsers: Chrome, Firefox.


QA Steps

  1. Disable the PP feature (either the beta feature or the user preference)
  2. Dwell on a link.
  3. Observe that the link's native tooltip appears.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 24 2017, 12:08 AM
Iniquity renamed this task from 'Title' parameter of <a> tag is dissapiring to 'Title' parameter of <a> tag is dissapiring in Russian Wikipedia.Mar 24 2017, 12:08 AM
Jack_who_built_the_house renamed this task from 'Title' parameter of <a> tag is dissapiring in Russian Wikipedia to 'Title' parameter of <a> tag is dissapearing in Russian Wikipedia.Mar 24 2017, 5:21 AM
Jack_who_built_the_house updated the task description. (Show Details)
Jack_who_built_the_house renamed this task from 'Title' parameter of <a> tag is dissapearing in Russian Wikipedia to 'Title' parameter of <a> tag is dissappearing in Russian Wikipedia.Mar 24 2017, 5:24 AM
Jack_who_built_the_house updated the task description. (Show Details)

Well, this is obviously done to prevent two "tooltips" in the same time.

The other problem is that it removes titles of all links, whether it is going to attach hovercard to it or not. It messes with some of the site's JavaScript, which adds links, and this is the problem that should be resolved.

Ricordisamoa renamed this task from 'Title' parameter of <a> tag is dissappearing in Russian Wikipedia to 'Title' parameter of <a> tag is disappearing in Russian Wikipedia.Mar 24 2017, 7:52 AM
Ricordisamoa renamed this task from 'Title' parameter of <a> tag is disappearing in Russian Wikipedia to 'Title' attribute of <a> tag is disappearing in Russian Wikipedia.
Ricordisamoa updated the task description. (Show Details)
Ricordisamoa updated the task description. (Show Details)
Iniquity updated the task description. (Show Details)Mar 27 2017, 11:05 PM

Now I got it.

The problem is actually very severe; many users reporting it. So, even if Hovercards are turned off, the 'title' attribute disappears.

Could someone please provide a list of steps with a testcase to reproduce the problem, which allow someone to just follow those steps without a need for interpretation and hopefully see the same problem? Also see https://mediawiki.org/wiki/How_to_report_a_bug - thanks.

  1. Open Russian Wikipedia (we have different Hovercards than others)
  2. If Hovercards are turn on then turn off Hovercards in Preferences.
  3. Mouseover on any link in main namespace.

Thanks, got it in Firefox 52:

Actual outcome:

  • Nothing happens.

Expected outcome:

  • Browser shows its own tooltip for that link with the title parameter displayed as text in that tooltip.
Aklapper renamed this task from 'Title' attribute of <a> tag is disappearing in Russian Wikipedia to Hovering over any link, no 'title' attribute of <a> tag is displayed in Russian Wikipedia.Mar 29 2017, 6:14 PM

@Aklapper thanks! Sorry for bad description.

Arbnos added a subscriber: Arbnos.Mar 29 2017, 6:37 PM
Jdlrobson triaged this task as High priority.Mar 29 2017, 9:41 PM
Jdlrobson added subscribers: ovasileva, phuedx, Jdlrobson.

^ @ovasileva @phuedx sounds high to me?

Change 345478 had a related patch set uploaded (by Phuedx):
[mediawiki/extensions/Popups@master] changeListeners: Conditionally empty link titles

https://gerrit.wikimedia.org/r/345478

phuedx claimed this task.Mar 30 2017, 8:47 PM
phuedx set the point value for this task to 2.
phuedx moved this task from Needs Analysis to Needs Code Review on the Reading-Web-Sprint-94 board.

Change 345478 merged by jenkins-bot:
[mediawiki/extensions/Popups@master] changeListeners: Conditionally empty link titles

https://gerrit.wikimedia.org/r/345478

phuedx reassigned this task from phuedx to ABorbaWMF.Mar 31 2017, 10:14 PM
phuedx moved this task from Ready for Signoff to Needs QA on the Reading-Web-Sprint-94 board.
phuedx updated the task description. (Show Details)Mar 31 2017, 10:19 PM

This should be available to test on the Beta Cluster.

Appears to be fixed. Tested on the following on the beta site.

Windows 10 - Firefox 42(x64)
Windows 10 - Chrome 57(x64)
Windows 8 - Firefox 50(x64)
Mac OSX 10.12 - Firefox 51
Mac OSX 10.10 - Chrome 55
Mac OSX 10.7 - Firefox 45

ovasileva closed this task as Resolved.Apr 4 2017, 10:08 AM
Iniquity reopened this task as Open.Apr 5 2017, 8:07 PM

Not yet. We are waiting for deploy.

Jdlrobson closed this task as Resolved.Apr 5 2017, 8:39 PM

@Iniquity the fix is on the deployment train and given it was merged Monday should be on Russian Wikipedia tomorrow by 4pm PST.
Correct protocol is to reopen the bug after that time has passed if the issue is still there. You can also use the Verified tag to confirm it as working.
Resolved in this context just means fixed in the codebase.
Hope that helps.

@Jdlrobson, wow, thanks! I didnt know that. This info is really helpful.

phuedx added a comment.Apr 6 2017, 8:33 AM

@Iniquity: ^ The above being said, thank you for taking the time to file this issue and remaining attentive!

Thanks for your work!

@phuedx Thank you too;)

Thanks for verifying @Iniquity !

@Jdlrobson , Thanks for telling me about the verification procedure :)