Page MenuHomePhabricator

Exception in module-execute in module ext.wikimediaEvents.loggedin: mw.Uri is not a constructor
Closed, ResolvedPublic

Description

I'm seeing the following JavaScript error in Chrome when logged in:

Exception in module-execute in module ext.wikimediaEvents.loggedin:
TypeError: mw.Uri is not a constructor TypeError: mw.Uri is not a constructor

This currently occurs for me on all pages on ca.wikipedia.org and pl.wikipedia.org, but not other sites I've tried. @jrobell
reports the same issue on es.wikipedia.org. When logged out, the error does not occur.

Details

Related Gerrit Patches:
mediawiki/extensions/WikimediaEvents : wmf/1.29.0-wmf.20Add missing dependency on mediawiki.Uri

Event Timeline

Pcoombe created this task.Apr 10 2017, 1:30 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 10 2017, 1:30 PM

Could someone who can reproduce the problem (I cannot) load the page with debug=true appended, and check which exact file triggers the TypeError in your web browser's developer tools please?

@Aklapper If I add debug=true the error no longer occurs

Wild guess (as said I cannot reproduce) from a non-developer: In extension.json, under ext.wikimediaEvents.loggedin, dependencies currently does not list "mediawiki.Uri". Maybe it should for those two occurrences of mw.Uri in modules/ext.wikimediaEvents.searchSatisfaction.js?

Change 348889 had a related patch set uploaded (by Krinkle; owner: Catrope):
[mediawiki/extensions/WikimediaEvents@wmf/1.29.0-wmf.20] Add missing dependency on mediawiki.Uri

https://gerrit.wikimedia.org/r/348889

This was discovered last week already and fixed in master. Backport was forgotten. Scheduling now.

Krinkle assigned this task to Catrope.Apr 19 2017, 6:44 PM
Krinkle triaged this task as High priority.

Change 348889 merged by jenkins-bot:
[mediawiki/extensions/WikimediaEvents@wmf/1.29.0-wmf.20] Add missing dependency on mediawiki.Uri

https://gerrit.wikimedia.org/r/348889

Mentioned in SAL (#wikimedia-operations) [2017-04-19T19:20:25Z] <krinkle@naos> Synchronized php-1.29.0-wmf.20/extensions/WikimediaEvents/extension.json: T162604 (duration: 01m 20s)

Krinkle closed this task as Resolved.Apr 19 2017, 7:27 PM