Page MenuHomePhabricator

Create Autor and Portal namespaces on Spanish Wikisource
Closed, ResolvedPublic

Description

Hello. I would like to ask for the creation of 2 new namespaces on Spanish Wikisource: "Autor" and "Portal".

The consensus was recently achived in this page:
https://es.wikisource.org/wiki/Wikisource:Votaciones/2017/Portales#Punto_6:_Nuevo_espacio_de_nombres

Thanks.

Details

Related Gerrit Patches:

Event Timeline

Aleator created this task.May 1 2017, 2:42 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 1 2017, 2:42 PM
Urbanecm claimed this task.May 2 2017, 4:30 AM
Urbanecm triaged this task as Medium priority.
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptMay 2 2017, 4:30 AM

esWS has

  • 100/1 free for "portal" and that gets the best xwiki matches

@Aleator you already have ns "Auxturo" at 102/3 how is this different?

esWS has

  • 100/1 free for "portal" and that gets the best xwiki matches

@Aleator you already have ns "Auxturo" at 102/3 how is this different?

Oh that is Helper: and looks like your Page: ns (esperanto Auxtoro means Author <facepalm>)

There is not good match, maybe use 108/9 as that is clear(er) on most wikisources

How is "Portal", "Portal talk", "Author" and "Author talk" said in Spanish?

Portal / Portal discusión

Autor / Autor discusión

Change 352250 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Create Autor and Portal namespaces on Spanish Wikisource

https://gerrit.wikimedia.org/r/352250

Urbanecm moved this task from Backlog to To deploy on the User-Urbanecm board.May 5 2017, 8:40 PM

Change 352250 merged by jenkins-bot:
[operations/mediawiki-config@master] Create Autor and Portal namespaces on Spanish Wikisource

https://gerrit.wikimedia.org/r/352250

Mentioned in SAL (#wikimedia-operations) [2017-05-09T13:44:26Z] <hashar@tin> Synchronized wmf-config/InitialiseSettings.php: Create Autor and Portal namespaces on Spanish Wikisource - T164195 (duration: 00m 39s)

hashar added a subscriber: hashar.May 9 2017, 1:45 PM

All links/articles fixed:

$ mwscript namespaceDupes.php --wiki=eswikisource 
0 pages to fix, 0 were resolvable.

0 links to fix, 0 were resolvable.

Looks good!

PLEASE REVERT! It was changed namespace Index to Author
Namespace 104 was Index. We needed new namespace, not delete an existent one!!!

An example is "Author" namespace (ns:102) on enWS. We could use the same namespace, you changed Autor to ns:104

Shooke added a subscriber: Shooke.May 10 2017, 1:26 PM

Revert PLEASE! This change https://gerrit.wikimedia.org/r/#/c/352250/2/wmf-config/InitialiseSettings.php IS WRONG. Like said Ninovolador, namespace 104 assigned to Index namespace, this change has caused a bug with indexes of books.

MarcoAurelio raised the priority of this task from Medium to Unbreak Now!.May 10 2017, 4:02 PM

Change broke namespaces (things that worked and now ain't was a valid rationale for UBN tasks). This should be reverted and/or fixed in the next SWAT window if at all possible.

Restricted Application added subscribers: Jay8g, TerraCodes, Dereckson. · View Herald TranscriptMay 10 2017, 4:02 PM

Sorry I have missed the notifications.

The change https://gerrit.wikimedia.org/r/352250 added:

+       'eswikisource' => [
+               100 => 'Portal', // T164195
+               101 => 'Portal_discusión', // T164195
+               104 => 'Autor', // T164195
+               105 => 'Autor_discusión', // T164195
+       ],

As a result, right now we have:

$ mwscript eval.php --wiki=eswikisource
> ksort($wgExtraNamespaces); var_export($wgExtraNamespaces);
array (
  100 => 'Portal',
  101 => 'Portal_discusión',
  102 => 'Página',
  103 => 'Página_Discusión',
  104 => 'Autor',
  105 => 'Autor_discusión',
)
> 

However $wgProofreadPageNamespaceIds is set with: page = 102 and index = 104.

Thus the issue is that the $wgExtraNamespace[104] = 'Autor'; overrides proof read page index.

NOTE: I have run namespaceDupes.php on the wiki after the deployment.
+----------------+----------+
| page_namespace | count(*) |
+----------------+----------+
...
|            100 |      532 |
|            101 |        1 |
|            102 |    79654 |
|            103 |       53 |
|            104 |     1414 |
|            105 |       11 |
|            828 |       51 |
|            829 |        2 |
+----------------+----------+

Potentially due to namespaceDupes.php, any page in NS_MAIN that started with Autor ended up being moved to namespace 104 which is for index of pages.

So most probably we should change Autor and Autor_discusion to 106 / 108 ?

I can not work on this right now but I am pinging people about it.

greg added a subscriber: greg.May 10 2017, 4:13 PM

@Dereckson are you able to help with this while Antoine is not able to work (due to other life commitments)?

I'm available around 17:30 UTC to look at this issue .

Dereckson added a comment.EditedMay 10 2017, 4:38 PM

But I can issue a revert now to restore previous state.

So plan is:

  1. Restore previous situation, all pages will be to old Index: namespace again.
  2. Note the page id to move to the future Author: namespace
  3. Commit a change for Author:
  4. Rename the pages in the bad namespaces, those noted in 2

Change 353107 had a related patch set uploaded (by Dereckson; owner: Dereckson):
[operations/mediawiki-config@master] Revert "Create Autor and Portal namespaces on Spanish Wikisource"

https://gerrit.wikimedia.org/r/353107

Change 353107 merged by jenkins-bot:
[operations/mediawiki-config@master] Revert "Create Autor and Portal namespaces on Spanish Wikisource"

https://gerrit.wikimedia.org/r/353107

So currently, the Index: namespace works again.

But there is probably Autor: pages renamed into Índice: too.

These are still to be renamed.

Dereckson lowered the priority of this task from Unbreak Now! to High.May 10 2017, 5:07 PM
Dereckson added a comment.EditedMay 10 2017, 6:23 PM

So there were some redirects from Autor: to main namespace created beforehand. Some was deleted, some was still alive.

The still alive list is available at P5415 thanks to Jaime.

You can for example see Autor:Santa_Teresa_de_Jesús is now Index::Santa_Teresa_de_Jesús

https://es.wikisource.org/w/index.php?title=%C3%8Dndice:Jos%C3%A9_Tom%C3%A1s_y_Garc%C3%ADa&redirect=no

You can rename these sixteen pages to Autor: now or after we reestablish, under a new id, the namespace.

See https://es.wikisource.org/wiki/Categor%C3%ADa:Portales_a_mejorar , previous Portal prefix problems, Portal:Argentina --> :Argentina

Change 353157 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Create Autor and Portal namespaces on Spanish Wikisource

https://gerrit.wikimedia.org/r/353157

Change 353157 merged by jenkins-bot:
[operations/mediawiki-config@master] Create Autor and Portal namespaces on Spanish Wikisource

https://gerrit.wikimedia.org/r/353157

Mentioned in SAL (#wikimedia-operations) [2017-05-10T20:33:37Z] <dereckson@tin> Synchronized wmf-config/InitialiseSettings.php: Restore Autor: and Portal: namespaces on es.wikisource (T164195) (duration: 00m 42s)

Mentioned in SAL (#wikimedia-operations) [2017-05-10T20:36:09Z] <Dereckson> Run namespaceDupes.php on es.wikisource (T164195)

Dereckson lowered the priority of this task from High to Medium.EditedMay 10 2017, 8:37 PM

@Shooke Now, https://es.wikisource.org/wiki/Portal:Alemania works again.

All looks in order, but there are still the sixteen renames any es.wikisource contributor can do following the P5415 list.

Thanks! @Dereckson, work fine all namespace!

Dereckson closed this task as Resolved.May 20 2017, 10:05 AM

Thank you @Dereckson for the follow up. I have completely missed following up on this task :(

You're welcome.