Page MenuHomePhabricator

Test reader survey in multiple languages - Romanian
Closed, ResolvedPublic

Description

rowiki

'enabled' => true,
'name' => 'Reader-segmentation-3-ro-test',
'type' => 'external',
'description' => 'Reader-segmentation-1-description', // (blank)
'link' => 'Reader-segmentation-3-link', // https://docs.google.com/forms/d/e/1FAIpQLSdkca5Cv_i4t8va9zg-chzfhBlCp9bBEIDMrz73KsHRyPD3RA/viewform?hl=ro
'question' => 'Reader-segmentation-3-message', // Răspundeți la 3 întrebări și ajutați-ne să îmbunătățim Wikipedia.
'privacyPolicy' => 'Reader-segmentation-3-privacy',
'coverage' => 0.5, // 1 out of 2
'platforms' => [
        'desktop' => [ 'stable' ],
        'mobile' => [ 'stable' ],
],
'instanceTokenParameterName' => 'entry.901222064',

Details

Related Gerrit Patches:
operations/mediawiki-config : masterDisable test reader QuickSurveys
operations/mediawiki-config : masterAdd QuickSurvey for reader segmentation research

Event Timeline

leila created this task.May 8 2017, 5:04 PM

coverage and privacyPolicy will be fixed.

We'll also need name and instanceTokenParameterName (if applicable)

leila added a comment.May 8 2017, 5:49 PM

@schana what were the values for these in the survey we ran last year on enwiki?

@leila I can prepare the patch if you can provide the parameters that should be in the config (Parameter descriptions, previous survey values).

leila added a comment.May 8 2017, 5:57 PM

@schana instanceTokenParameterName points to entry.901222064. Do you know where I should look for that? I don't find anything under MediaWiki:entry.901222064

leila added a comment.May 8 2017, 6:13 PM

@schana I'm still unsure where the data that is passed via this parameter sits. In the description of the task, for example, where have we stored "547576563876"?

@leila From my understanding this is a way to link the EventLogging data to the survey results. That is, it is logged with EventLogging and also pre-fills the survey with a random value in a field named with whatever is in InstanceTokenParameterName.

leila added a comment.May 9 2017, 3:54 AM

agreed, but I'm not sure what I should provide to you. Basically, it seems to me that entry.901222064 in this code is linking to a file or database where the unique IDs for the survey are stored (and these IDs are the same as the ones you mentioned, each time a survey is going to be taken by a participant, a unique number from that file/database is allocated to the survey (and that helps us connect the responses to EventLogging). Can you look into where entry.901222064 points to for that specific example and let me know what exactly I should provide to you and where?

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptMay 9 2017, 10:07 AM
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Aklapper reopened this task as Open.May 9 2017, 10:19 AM

The entry.1234 parameter name comes from the URL generated when using the "Get pre-filled link" option when creating the form. To find out what it'll be for this survey, go through the "Get pre-filled link" dialog and make note of the resulting url.

@schana: just to clarify responsibilities, @leila needs to provide high level specs on the expected behavior (e.g. "we need a token to be generated that is unique to the response and can be used to match the instrumentation data we obtain via EventLogging"). It's your job to implement this, let her know how the storage of this data will work and coordinate with her on any data quality issue. This last part of the task:

To find out what it'll be for this survey, go through the "Get pre-filled link" dialog and make note of the resulting url.

is something I expect you to do, not @leila. If the issue is that you don't have access to the survey configuration, please request it.

@DarTar Going through that dialog takes <1 minute, but I am happy to do it if it's expected.

@leila Can you add me as a collaborator to the survey so I can get the correct parameter name?

leila added a comment.May 9 2017, 11:47 PM

@leila Can you add me as a collaborator to the survey so I can get the correct parameter name?

done. please update the task description and the corresponding links (if you have edit access) if the survey link changes, @schana .

leila updated the task description. (Show Details)May 10 2017, 12:55 AM

@schana please check the code to make sure that "coverage" actually functions the way we mean it, as in: when we set the value to 0.5, it actually does 1 out of 2 sampling.

leila reassigned this task from leila to schana.May 10 2017, 1:30 AM
leila added a comment.May 10 2017, 1:54 AM

@schana can you prepare everything for the surveys to go live on Thursday in 13:00-14:00 UTC SWAT time and stop after 18:00-19:00 UTC the same day? Please take a note of exact start and end time of the test in the task description.

schana updated the task description. (Show Details)May 10 2017, 11:47 AM

@leila We still need a name value.

Change 353053 had a related patch set uploaded (by Nschaaf; owner: Nschaaf):
[operations/mediawiki-config@master] Add QuickSurvey for reader segmentation research

https://gerrit.wikimedia.org/r/353053

leila added a comment.May 10 2017, 3:20 PM

@leila We still need a name value.

@schana does the user see the name anywhere or is this for internal tracking?

@schana does the user see the name anywhere or is this for internal tracking?

It's only used for internal tracking as far as I can tell. The previous survey used a value of Reader-segmentation-1, which doesn't have a corresponding MediaWiki: page. I'm not sure if there are implications of using the same name for different wikis, but it may be safest if the names are different for each language.

leila added a comment.May 10 2017, 4:53 PM

got it. thanks. I'll update the description.

leila updated the task description. (Show Details)May 10 2017, 4:56 PM
leila moved this task from Staged to In Progress on the Research board.May 10 2017, 5:08 PM

Change 353053 merged by jenkins-bot:
[operations/mediawiki-config@master] Add QuickSurvey for reader segmentation research

https://gerrit.wikimedia.org/r/353053

Stashbot added a subscriber: Stashbot.

Mentioned in SAL (#wikimedia-operations) [2017-05-15T13:10:55Z] <addshore@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:353053|Add QuickSurvey for reader segmentation research]] T131949 T164769 T164894 T164960 T164963 (duration: 00m 40s)

Change 353876 had a related patch set uploaded (by Nschaaf; owner: Nschaaf):
[operations/mediawiki-config@master] Disable test reader QuickSurveys

https://gerrit.wikimedia.org/r/353876

The surveys were deployed at 1310 UTC. The first impression for rowiki was at 1311 UTC.

Change 353876 merged by jenkins-bot:
[operations/mediawiki-config@master] Disable test reader QuickSurveys

https://gerrit.wikimedia.org/r/353876

Mentioned in SAL (#wikimedia-operations) [2017-05-15T18:20:39Z] <catrope@tin> Synchronized wmf-config/InitialiseSettings.php: Disable test reader QuickSurveys (T131949, T164769, T164894, T164960, T164943) (duration: 00m 40s)

schana removed a project: Patch-For-Review.

The surveys were disabled at 1820 UTC. The impressions mostly stopped after 1830 UTC.

leila closed this task as Resolved.Jun 18 2017, 11:16 AM