Page MenuHomePhabricator

Repeat the big English reader survey in one or two more languages
Closed, ResolvedPublic

Description

Repeat T125946 in one or two more languages.

The languages are chosen by a mix of community interest to have the results available in their language as well as identifying languages that can help Research and Reading teams expand their understanding of the reader base.

Details

Related Gerrit Patches:
operations/mediawiki-config : masterStop reader surveys
operations/mediawiki-config : masterEnable Reader Survey using QuickSurveys
operations/mediawiki-config : masterDisable test reader QuickSurveys
operations/mediawiki-config : masterAdd QuickSurvey for reader segmentation research

Related Objects

StatusAssignedTask
Resolvedleila
Resolvedleila
Resolved schana
Resolved schana
Resolved schana
Resolved schana
ResolvedNone
Resolved schana
Resolved schana
Resolved schana
Resolved schana
Resolved schana
Resolved schana
Resolved schana
Resolved schana
Resolved schana
Resolved schana
Resolved schana
Resolved schana
Resolved schana
Resolved schana
Resolved schana
DeclinedNone
Resolvedflemmerich

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes

Change 353053 merged by jenkins-bot:
[operations/mediawiki-config@master] Add QuickSurvey for reader segmentation research

https://gerrit.wikimedia.org/r/353053

Mentioned in SAL (#wikimedia-operations) [2017-05-15T13:10:55Z] <addshore@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:353053|Add QuickSurvey for reader segmentation research]] T131949 T164769 T164894 T164960 T164963 (duration: 00m 40s)

Change 353876 had a related patch set uploaded (by Nschaaf; owner: Nschaaf):
[operations/mediawiki-config@master] Disable test reader QuickSurveys

https://gerrit.wikimedia.org/r/353876

Change 353876 merged by jenkins-bot:
[operations/mediawiki-config@master] Disable test reader QuickSurveys

https://gerrit.wikimedia.org/r/353876

Mentioned in SAL (#wikimedia-operations) [2017-05-15T18:20:39Z] <catrope@tin> Synchronized wmf-config/InitialiseSettings.php: Disable test reader QuickSurveys (T131949, T164769, T164894, T164960, T164943) (duration: 00m 40s)

DarTar renamed this task from Repeat the big English reader survey in one or two more languages to [Epic] Repeat the big English reader survey in one or two more languages .May 18 2017, 2:54 AM

Change 359936 had a related patch set uploaded (by Nschaaf; owner: Nschaaf):
[operations/mediawiki-config@master] Enable Reader Survey using QuickSurveys

https://gerrit.wikimedia.org/r/359936

Change 359936 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable Reader Survey using QuickSurveys

https://gerrit.wikimedia.org/r/359936

Mentioned in SAL (#wikimedia-operations) [2017-06-22T13:09:30Z] <hashar@tin> Synchronized wmf-config/InitialiseSettings.php: Enable Reader Survey using QuickSurveys - T131949 (duration: 01m 04s)

Mentioned in SAL (#wikimedia-operations) [2017-06-22T13:09:30Z] <hashar@tin> Synchronized wmf-config/InitialiseSettings.php: Enable Reader Survey using QuickSurveys - T131949 (duration: 01m 04s)

The surveys are now live

Change 360849 had a related patch set uploaded (by Nschaaf; owner: Nschaaf):
[operations/mediawiki-config@master] Stop reader surveys

https://gerrit.wikimedia.org/r/360849

Mentioned in SAL (#wikimedia-operations) [2017-06-22T19:09:45Z] <thcipriani@tin> Started scap: SWAT: [[gerrit:360889|Translation updates for QuickSurveys]] T131949

Mentioned in SAL (#wikimedia-operations) [2017-06-22T19:31:55Z] <thcipriani@tin> Finished scap: SWAT: [[gerrit:360889|Translation updates for QuickSurveys]] T131949 (duration: 22m 10s)

Mentioned in SAL (#wikimedia-operations) [2017-06-22T19:31:55Z] <thcipriani@tin> Finished scap: SWAT: [[gerrit:360889|Translation updates for QuickSurveys]] T131949 (duration: 22m 10s)

This updated the translations for the survey buttons for (ar, hi, hu, ja, nl, ro)

leila added a comment.Jun 25 2017, 1:03 PM

Mentioned in SAL (#wikimedia-operations) [2017-06-22T19:31:55Z] <thcipriani@tin> Finished scap: SWAT: [[gerrit:360889|Translation updates for QuickSurveys]] T131949 (duration: 22m 10s)

This updated the translations for the survey buttons for (ar, hi, hu, ja, nl, ro)

It seems this didn't fix the issue. Users in rowiki are reporting that they still see the two buttons in English. I just tested the Arabic version and the issue persists there as well.

elukey added a subscriber: elukey.Jun 25 2017, 2:11 PM

Reporting some conversation happened in IRC:

  • When https://gerrit.wikimedia.org/r/#/c/360889 got deployed the surveys were displayed with the correct translations.
  • For some reason now the translations are gone and one can only see the English ones.
  • Forcing X-Wikimedia-Debug to mw2017 renders the correct translations.

How to repro:

https://ro.wikipedia.org/w/index.php?title=Ozer%C8%9Bi_(Ozer%C8%9Bi),_Volod%C3%AEm%C3%AEre%C8%9B&quicksurvey=true

Bottom-right there is a box with the title "Răspundeți la 3 întrebări și ajutați-ne să îmbunătățim Wikipedia", showing two buttons in english "visit page" "no thanks".

Mentioned in SAL (#wikimedia-operations) [2017-06-22T19:31:55Z] <thcipriani@tin> Finished scap: SWAT: [[gerrit:360889|Translation updates for QuickSurveys]] T131949 (duration: 22m 10s)

This updated the translations for the survey buttons for (ar, hi, hu, ja, nl, ro)

It seems this didn't fix the issue. Users in rowiki are reporting that they still see the two buttons in English. I just tested the Arabic version and the issue persists there as well.

It seems that the messages were available on the wikis (confirmed by checking https://ro.wikipedia.org/wiki/MediaWiki:Ext-quicksurveys-external-survey-yes-button); however, the messages were not available in resourceloader on the wikis. I come to this conclusion since following the instructions
here: https://wikitech.wikimedia.org/wiki/How_to_deploy_code#ResourceLoader_and_l10n_messages seems to have cleared things up.

I've run into this before when scaping out new l10n updates, usually I flail at it until @Catrope or @Krinkle jump in to help. @Catrope or @Krinkle is there something that can be built into scap to clear out the resourceloader cache on l10nupdate? Some manual step that needs to be done? I believe we normally side-step this problem with many critical l10nupdates as they happen as part of the train. (filed this as T168790: scap and resourceloader l10n)

@schana can you schedule for all surveys to stop at 2300 UTC today? I'm talking with Bob and Florian, hopefully in 2.5 hours, and we will finalize the decision then but given that most probably we will want to stop, it's good to schedule it. I will confirm here by 17:00 UTC.

@schana can you schedule for all surveys to stop at 2300 UTC today? I'm talking with Bob and Florian, hopefully in 2.5 hours, and we will finalize the decision then but given that most probably we will want to stop, it's good to schedule it. I will confirm here by 17:00 UTC.

@leila Will you be available for the SWAT? If not, can we push it up to the 1800 UTC slot?

leila added a comment.Jun 29 2017, 2:38 PM

@schana

@leila Will you be available for the SWAT?

I will be around during that time but my understanding is that a developer will need to be around and me being around won't help.

If not, can we push it up to the 1800 UTC slot?

The five languages that had an issue with their widget translations are recovering from that issue (which was fixed on Sunday) and it's safer if we get more data from all surveys for another few hours before stopping them.

@leila The patch is written (https://gerrit.wikimedia.org/r/#/c/360849/), but I won't be available for the 2300 UTC time slot. Is there another developer who can do the SWAT? If not, I can do it July 5 at 1300 UTC (next available SWAT).

leila added a comment.Jun 29 2017, 2:49 PM

I'll look for another developer, @schana .

I've scheduled this for SWAT today.

Krinkle removed a subscriber: Krinkle.Jun 29 2017, 8:31 PM

Change 360849 merged by jenkins-bot:
[operations/mediawiki-config@master] Stop reader surveys

https://gerrit.wikimedia.org/r/360849

Mentioned in SAL (#wikimedia-operations) [2017-06-29T23:19:12Z] <catrope@tin> Synchronized wmf-config/InitialiseSettings.php: Stop reader surveys (T131949) (duration: 00m 43s)

@Jdlrobson I did one test in each of the 14 languages and I confirm that the surveys have stopped. Thanks for your help! :)

ggellerman closed this task as Resolved.Jul 17 2017, 6:34 PM
ggellerman edited projects, added Research-Archive; removed Research.
leila reopened this task as Open.Jul 25 2017, 2:56 PM
leila edited projects, added Research; removed Research-Archive, Patch-For-Review.
leila moved this task from Done (current quarter) to Time Sensitive on the Research board.
leila moved this task from Time Sensitive to Staged on the Research board.
leila renamed this task from [Epic] Repeat the big English reader survey in one or two more languages to Repeat the big English reader survey in one or two more languages .Jul 25 2017, 4:45 PM
leila closed this task as Resolved.