add Bugzilla to unified login (SUL)
Closed, DeclinedPublic

Description

Author: charlottethewebb

Description:
oh come on... please?


Version: unspecified
Severity: enhancement

bzimport added a project: Wikimedia-Bugzilla.Via ConduitNov 21 2014, 10:13 PM
bzimport added a subscriber: Unknown Object (MLST).
bzimport set Reference to bz14487.
bzimport created this task.Via LegacyJun 9 2008, 5:04 PM
bzimport added a comment.Via ConduitJun 9 2008, 9:43 PM

soxred93 wrote:

This is a wikimedia issue.

brion added a comment.Via ConduitJun 9 2008, 11:54 PM

Not sure what it would take to integrate the foreign logins... could be creepy... :D

siebrand added a comment.Via ConduitAug 13 2008, 9:32 PM

Nah: WONTFIX.

bzimport added a comment.Via ConduitOct 25 2010, 6:24 AM

Phuzion825 wrote:

I realize this is an old bug, but is there a legitimate reason for not wanting to do this, or is it just a low return on investment for the effort required to get it working?

Bawolff added a comment.Via ConduitOct 25 2010, 10:52 AM

(In reply to comment #4)

I realize this is an old bug, but is there a legitimate reason for not wanting
to do this, or is it just a low return on investment for the effort required to
get it working?

(This is just my personal opinion. Actual reasons could be different). Probably mostly the latter. All mediawiki wikis use the same type of login system, which we (as mediawiki devs) are quite familiar with, well bugzilla uses some other sort of system which we know nothing about. Thus its harder (we'd have to figure out how bugzilla does its login system) for no real benefit.

There's also the secondary issue that in bugzilla emails are rather public where on wiki your email address is considered sensitive information and never shown to the public.

Kozuch added a comment.Via ConduitFeb 3 2013, 10:15 AM

This is an example of really stupid WONTFIX resolution. There is no, absolutely no reason why this Bugzilla could not work with SUL. Most of us acknowledge we need a better issue reporting system and this would definitely be an easier step than employing completely new software instead of Bugzilla. So I can not see a legitimate reason for wontfixing this.

As for the emails publicity - this can be solved by making the user provide such email with first SUL login here... and save the email only locally here for Bugzillas use.

Bawolff added a comment.Via ConduitFeb 3 2013, 10:52 AM

(In reply to comment #6)

This is an example of really stupid WONTFIX resolution. There is no,
absolutely
no reason why this Bugzilla could not work with SUL. Most of us acknowledge
we
need a better issue reporting system and this would definitely be an easier
step than employing completely new software instead of Bugzilla. So I can not
see a legitimate reason for wontfixing this.

As for the emails publicity - this can be solved by making the user provide
such email with first SUL login here... and save the email only locally here
for Bugzillas use.

Ok re-opened. But realistically this is a super low priority thing (lots of work for very little gain). However, if someone wants to code up a patch (bugzilla extension?) for this - by all means.

Kozuch added a comment.Via ConduitFeb 3 2013, 6:52 PM

Thanks for reopening. We could talk about the priorities (who does set them?) - in the scope of editor retention struggle, I think exactly this but has an indirect impact on the whole editing environment... if something sucks an editor, the best for him is to post it somewhere (like here)...

Bawolff added a comment.Via ConduitFeb 3 2013, 7:03 PM

(In reply to comment #8)

Thanks for reopening. We could talk about the priorities (who does set
them?) -
in the scope of editor retention struggle, I think exactly this but has an
indirect impact on the whole editing environment... if something sucks an
editor, the best for him is to post it somewhere (like here)...

Generally a developer who works in the relavent area of the code base. More generally Andre sets them.

Just keep in mind every bug is important to someone, but if every bug had a high priority it would defeat the point of setting priorities.

As for things sucking - more often than not what happens is people post to the local village pump and a technical user distills the technical details and posts it over here.

Aklapper added a comment.Via ConduitMar 8 2013, 4:05 PM
  • Bug 45899 has been marked as a duplicate of this bug. ***
Qgil added a comment.Via ConduitMar 18 2013, 4:07 PM

Perhaps we can have account connected, even if they don't have exactly the same credentials in each tool? Account creation at http://wikitech.wikimedia.org manages to create a MediaWiki and a Gerrit user account in one go.

I personally don't mind about login in Bugzilla or Gerrit not using exactly the same credentials but it is useful to know what accounts in the different tools belong to a same person, and connect them somehow.

This discussion is relevant in the context of https://www.mediawiki.org/wiki/User:Qgil/Contributors , where a connection between MediaWiki accounts and their corresponding Bugzilla accounts would be useful.

Aklapper added a comment.Via ConduitAug 7 2013, 3:44 AM
  • Bug 52595 has been marked as a duplicate of this bug. ***
Qgil added a comment.Via ConduitSep 16 2013, 9:08 PM

Just in case this is relevant:

Currently Wikimedia (Wikipedia, Meta, mediawiki.org...) and Wikitech (Gerrit...) accounts are separate and afaik there are no plans to merge them. To which one should Bugzilla be connected? The subject of the report talks about SUL (Wikimedia). However, I think it makes more sense to connect the Bugzilla account with your Wikitech & Gerrit accounts.

The scope of Bugzilla is better aligned with the scope of Wikitech / Gerrit.

Deskana added a comment.Via ConduitSep 16 2013, 11:25 PM

I think it's important to remember why this request was being made. Staff often complain that volunteers aren't filing bugs on Bugzilla enough, and are instead leaving their complaints about bugs either in strange places, or nor making them at all. This, I suspect, is because people can't remember their Bugzilla logins, as I admit I've gotten developers to file bugs for me before simply because I couldn't figure out how to log in to Bugzilla.

Given the above, linking Bugzilla to Wikitech logins does nothing whatsoever to address the actual underlying issue. We want to be making it easier for your average user to access Bugzilla, as that gives them the best way to spot things and include them in our workflows. Therefore, I think we need Bugzilla to be linked to SUL.

MZMcBride added a comment.Via ConduitSep 18 2013, 1:55 AM

(In reply to comment #15)

I think it's important to remember why this request was being made. Staff
often complain that volunteers aren't filing bugs on Bugzilla enough, and are
instead leaving their complaints about bugs either in strange places, or nor
making them at all.

The canonical place for leaving feedback is the wiki.

We want to be making it easier for your average user to access Bugzilla, as
that gives them the best way to spot things and include them in our workflows.
Therefore, I think we need Bugzilla to be linked to SUL.

Ehhhh, I'm not sure we do want this. It's a balancing act. We certainly do _not_ want to turn Bugzilla into something similar to OTRS or AFTv5.

I don't really buy the argument that users can't remember an e-mail address and password. If _you_ can't remember an e-mail address and password and consequently can't file a bug here, that sounds like a personal problem. :-) Bugzilla is hardly unique in requiring authentication. It might be a nice enhancement request to tie into other auth systems, but again, it's a balancing act.

Deskana added a comment.Via ConduitSep 18 2013, 2:59 AM

(In reply to comment #16)

The canonical place for leaving feedback is the wiki.

I don't have an issue with that. But there are some users who like to use Bugzilla, and if we can make that easier, I'm all for that.

I don't really buy the argument that users can't remember an e-mail address
and
password. If _you_ can't remember an e-mail address and password and
consequently can't file a bug here, that sounds like a personal problem. :-)

My problem often exists between the keyboard and the chair. ;-)

I don't really expect this to be a silver bullet that fixes everything. But I do think that, given the choice between tying Bugzilla authentication into either SUL or Wikitech accounts, I'd definitely choose SUL.

Aklapper added a comment.Via ConduitSep 18 2013, 4:55 PM

As already mentioned before, this issue and bug 148 (email address exposed to logged-in Bugzilla users) are by far the top complaints I see in Village Pumps when I ask people to go to Bugzilla. I must admit that it's not clear to me if using SUL or Gerrit/Wikitech logins might also influence bug 148 as a side-effect.

It's a balancing act.

Yes. I often point users on Village Pumps etc. to https://www.mediawiki.org/wiki/How_to_report_a_bug to raise awareness that there is a bugtracker that developers are supposed to look into.
I'd like to make it easier and more convenient for users to report tickets into Bugzilla (for example, working on a guided bug entry form in bug 36762 that anybody can test on http://boogs.wmflabs.org/enter_bug.cgi?product=Wikimedia&format=guided ) but on the other hand I don't want Bugzilla to become too noisy or lowlevel, because you'd end up with more developers ignoring their bugmail and not considering Bugzilla a useful place anymore. So yeah, it's hard.

If we go for SUL instead of Gerrit/Wikitech, we likely need to make way more clear (improve documentation and make people see this documentation, e.g. in Bugzilla itself) that this is not another wiki and that comments should really be kept ontopic.

Qgil added a comment.Via ConduitSep 19 2013, 4:44 AM

There is an (imho) important factor to consider: Bugzilla has the same scope than Gerrit (and hence the wikitech.w.o login): MediaWiki Core + Extensions + some Wikimedia specific stuff.

Consequences:

  • It is good for Wikipedia users to understand that when they are filing a bug report o feature request here, most probably it relates to and depends on other technical factors beyond his/her specific Wikimedia project.
  • It is also good not to "force" a Wikipedia login to the non-Wikimedia users and sysadmins reporting MediaWiki problems and feature requests here, since this is also their place. And we suffer from enough Wikimedia-centrism already in this open source project. (as a reminder, these users are currently wondering why they need a mediawiki.org login, a different one for Gerrit/wikitech.m.o and another one for Bugzilla).

As a side effect, being Bugzilla next to Gerrit does minimize the problem of having public email addresses, since this is just normal for anybody contributing patches, as opposed to wiki editors who never have to disclose publicly this information.

Qgil added a comment.Via ConduitMay 16 2014, 4:17 AM

Related discussion about supporting SUL in Wikimedia Phabricator:

http://fab.wmflabs.org/T40

For background about Phabricator, see [[mw:Phabricator]].

Aklapper closed this task as "Declined".Via WebNov 23 2014, 11:23 PM
Aklapper claimed this task.

Wikimedia has migrated from Bugzilla to Phabricator. Hence closing as "declined".

Phabricator offers using your mediawiki.org account for login via OAuth, hence this is resolved/fixed in Phabricator terms.

Kozuch awarded a token.Via WebDec 17 2014, 8:09 PM

Add Comment