Page MenuHomePhabricator

revoke benefactorevents.wikimedia.org SSL certificate
Closed, ResolvedPublic

Description

The fate of the hostname benefactorevents.wikimedia.org is in limbo as we work with the Fundraising Endowment team to figure out what the transition from Trilogy to new vendor Impact Flow should look like. We are currently waiting for specs from Impact Flow about what options we have for URL and hostname, and it's not clear whether we want to continue using the benefactorevents FQDN.

For now we should revoke the current benefactorevents.wikimedia.org SSL certificate.

Note: Both Trilogy and Impact Flow provide a SAAS events management platforms, which Endowment uses for managing donor events.

Details

Related Gerrit Patches:

Related Objects

StatusAssignedTask
OpenBBlack
ResolvedBBlack
ResolvedArielGlenn
ResolvedChmarkine
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedCCogdill_WMF
DeclinedBBlack
DuplicateBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedJgreen
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedJgreen
ResolvedRobH

Event Timeline

Jgreen created this task.Jul 10 2017, 1:00 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 10 2017, 1:00 PM
Jgreen added a parent task: Restricted Task.Jul 10 2017, 1:15 PM
RobH claimed this task.Jul 11 2017, 4:24 PM
RobH added a comment.Jul 11 2017, 4:55 PM

Please note benefactorevents.wikimedia.org doesn't expire until 04/02/2018. Since this private key is accessible by a third party (Trilogy), I'm revoking the certificate as requested.

Change 364472 had a related patch set uploaded (by RobH; owner: RobH):
[operations/puppet@production] remove benefactorevents.w.o cert as its been revoked

https://gerrit.wikimedia.org/r/364472

Change 364473 had a related patch set uploaded (by RobH; owner: RobH):
[operations/dns@master] remove benefactorevents.w.o from dns

https://gerrit.wikimedia.org/r/364473

Change 364472 merged by RobH:
[operations/puppet@production] remove benefactorevents.w.o cert as its been revoked

https://gerrit.wikimedia.org/r/364472

Change 364473 merged by RobH:
[operations/dns@master] remove benefactorevents.w.o from dns

https://gerrit.wikimedia.org/r/364473

RobH closed this task as Resolved.Jul 11 2017, 5:03 PM

Revocation Request Completed for benefactorevents.wikimedia.org - confirmed from globalsign.

I've gone ahead and removed the key/cert from our repos, as well as DNS.