Page MenuHomePhabricator

delete links.email.donate.wikimedia.org (and all other email.donate.*?) from DNS
Closed, ResolvedPublic

Description

see parent task at T74514#2054108 and following

"So is links.email.donate.wikimedia.org still in use? If not, can we remove it from the DNS record?"

"It will be in use for another couple of weeks, until the Swedish banners
come down. ... I can update this task once all the Swedish emails are out."

This ticket is for that update and removing it from DNS

Details

Related Gerrit Patches:

Event Timeline

Dzahn created this task.Mar 18 2016, 8:55 PM
Restricted Application added subscribers: Josve05a, Aklapper. · View Herald TranscriptMar 18 2016, 8:55 PM

My comment was incorrect, this domain is no longer in use. Feel free to delete the DNS record!

Dzahn added a comment.Mar 18 2016, 9:15 PM

How about this one:

open.email.donate.wikimedia.org

When i look at DNS i see these 2 lines, related to mkt41

links.email.donate 1H IN CNAME recp.mkt41.net.
open.email.donate 1H IN CNAME open.mkt41.net.

Change 278353 had a related patch set uploaded (by Dzahn):
delete links.email.donate.wikimedia.org

https://gerrit.wikimedia.org/r/278353

Would it be possible to get a full list of DNS entries you want to remove?

I’m seeing A, MX, CNAME and TXT records we likely can remove. Looking
through old tickets, anything that is *.email.donate.wikimedia.org should
be able to go. I’m 90% certain we can remove those. Open tracking is now at
http://links.wikimedia.mkt4477.com/open/*

Removing DNS kind of makes me nervous, and over the years our DNS has been
updated several times. Can we coordinate a time on when these are all
removed? Then we should have 48 hours planned without sending any email.

Dzahn added a comment.EditedMar 18 2016, 9:49 PM

So far i just wanted to delete links.email.donate.wikimedia.org
(because it was listed on https://wikitech.wikimedia.org/wiki/Httpsless_domains and i saw the bug link there)

then i saw the "open.email.donate" and now since you said that, yes there is more with "email.donate" in it.

we also have:

spop1024._domainkey.email.donate
bounce.email.donate
email.donate
mail3880.email.donate
reply.email.donate
open.email.donate
www.email.donate

But i know nothing about them and agree, it would also make me nervous to delete more of that, especially now before the long weekend. So i won't make any change today and we should investigate this to make really sure.

Dzahn renamed this task from delete links.email.donate.wikimedia.org from DNS to delete links.email.donate.wikimedia.org (and all other email.donate.*?) from DNS.Mar 18 2016, 9:50 PM

Great, thanks @Dzahn. We're double checking this list with IBM to be extra careful, so I'll confirm by Tuesday that this looks OK to remove on our end. If you come across any others you want to look into removing, let me know.

@CCogdill_WMF Sounds great. thank you. They should be all. this is the full list i find with grep across the repository with the DNS templates.

~/wmf/dns/templates$ grep "email.donate" wikimedia.org

spop1024._domainkey.email.donate 1H IN TXT  "k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQCnPE/TvQbvCk0FbqekfcpB7R6R9yXFulninKCCagEijzf/55WqL3o9mNMddmmEAIQvhlscYqtrEerd2RYQTo0pNjJQAXIddvhUaJo+r66TYoyTSoxtL6zF7oJ9ZOL9i7PIntN7zq7m448S/3llWKK8MDvkeG+f5MN/qZ+P2wyD+QIDAQAB"
bounce.email.donate     1H  IN A    74.121.50.42
bounce.email.donate     1H  IN MX   5 bounce.email.donate
bounce.email.donate     1H  IN TXT  "v=spf1 ip4:74.121.51.111 ip4:208.80.155.11 -all"
email.donate            600 IN DYNA geoip!text-addrs/eqiad
email.donate            1H  IN MX   10 reply.email.donate
email.donate            1H  IN MX   20 mail3880.email.donate
email.donate            1H  IN TXT  "v=spf1 ip4:74.121.51.111 ip4:208.80.155.11 -all"
mail3880.email.donate   1H  IN A    74.121.51.111
mail3880.email.donate   1H  IN MX   5 mail3880.email.donate
mail3880.email.donate   1H  IN TXT  "v=spf1 ip4:74.121.51.111 ip4:208.80.155.11 -all"
reply.email.donate      1H  IN A    74.121.50.42
reply.email.donate      1H  IN MX   5 reply.email.donate
reply.email.donate      1H  IN TXT  "v=spf1 ip4:74.121.51.111 ip4:208.80.155.11 -all"
open.email.donate       1H  IN CNAME open.mkt41.net.
www.email.donate        1H  IN CNAME wikimedia.org.
Josve05a removed a subscriber: Josve05a.Mar 23 2016, 4:24 PM

@Dzahn I've confirmed it's fine on our side to delete all the subdomains
you listed from the DNS. Please just give us a heads up before you do it,
and we will put a cautionary hold on sending bulk email. Tuesday or Friday
would be best for our send schedule, but I can be flexible with a little
heads up :)

Dzahn added a comment.Apr 1 2016, 10:41 PM

@CCogdill_WMF Sorry, i didn't get to this yet and now it's Friday again and i will be on vacation for a week. I'll get back to this after April 9th and we can figure out a date. Thanks again.

No problem, thanks for keeping me updated @Dzahn. Have a nice vacation!

Dzahn added a comment.Apr 12 2016, 2:52 PM

Hi @CCogdill_WMF i'm back and you said Tuesday or Friday are good days for your schedule. Could we do it today?

Sure @Dzahn, I can make today work.

Dzahn added a subscriber: BBlack.Apr 12 2016, 3:47 PM

@CCogdill_WMF @BBlack great, we can merge it now then it looks

Change 278353 merged by Dzahn:
delete *.email.donate.wikimedia.org

https://gerrit.wikimedia.org/r/278353

Dzahn added a comment.Apr 12 2016, 3:57 PM

@CCogdill_WMF We have merged the config change on the DNS servers. Changes should be noticable within an hour since the TTL for the records was set to 1H. Let us know if any issues pop up, and thank you very much!

BBlack closed this task as Resolved.Apr 12 2016, 3:57 PM
CCogdill_WMF raised the priority of this task from High to Unbreak Now!.Apr 12 2016, 6:18 PM

Hi @Dzahn, I think a record was deleted that we didn't discuss. "spop1024._domainkey.wikimedia.org" is gone, and we were only supposed to remove "spop1024._domainkey.email.donate.wikimedia.org". Can we add this back ASAP? Thank you!

Dzahn reopened this task as Open.Apr 12 2016, 6:20 PM

yes, checking

Change 282984 had a related patch set uploaded (by Dzahn):
re-add silverpop domainkey entry for fundraising

https://gerrit.wikimedia.org/r/282984

Change 282984 merged by Dzahn:
re-add silverpop domainkey entry for fundraising

https://gerrit.wikimedia.org/r/282984

Dzahn added a comment.EditedApr 12 2016, 6:26 PM

Hi @Dzahn, I think a record was deleted that we didn't discuss. "spop1024._domainkey.wikimedia.org" is gone, and we were only supposed to remove "spop1024._domainkey.email.donate.wikimedia.org". Can we add this back ASAP? Thank you!

@CCogdill_WMF I have added it back, sorry about that.

https://gerrit.wikimedia.org/r/#/c/282984/2/templates/wikimedia.org

Whew, thanks so much for the quick fix!

Dzahn closed this task as Resolved.Apr 12 2016, 6:29 PM