Page MenuHomePhabricator

As a MediaWiki.org admin or Newsletter publisher, I cannot manage my own newsletter
Closed, ResolvedPublic

Description

This is strange. I have created two almost identical newsletters in test.wikipedia and MediaWiki.org. When I click "Manage", it works on test.wikipedia, but not in MW.o. I believe I have the same permissions in both wikis (administrator and publisher of that newsletter).

Both pages look the same, as an admin/publisher I see the same buttons. However, clicking "Manage", in MW.o I stay in the same page.

Introducing the URL manually, I also end up in the same page:

Event Timeline

Qgil created this task.Sep 7 2017, 1:00 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 7 2017, 1:00 PM
Qgil added a comment.Sep 7 2017, 1:04 PM

I wonder whether it has to do with database permissions. A cannot open/update database kind of thing.

Clicking on "Announce", I do land in https://www.mediawiki.org/wiki/Special:Newsletter/1/announce. And the announcements work. I just sent a Hello World! one (with the secret intention of testing).

It looks like this is something to do with some interaction between the TwoColConflict extension and Newsletter

Restricted Application added a project: TCB-Team. · View Herald TranscriptSep 7 2017, 1:40 PM
Addshore claimed this task.Sep 7 2017, 1:41 PM
Addshore added a project: User-Addshore.

The onCustomEditor hook in TwoColConflict returns false when the TwoColConflict extension is enabled and the user is using the feature.
As a result the onCustomEditor hook for Newsletter is never fired.

It looks like this was actually caused by https://gerrit.wikimedia.org/r/#/c/329202

In the short-term I'd recommend reverting my commit (https://gerrit.wikimedia.org/r/#/c/329202), which was just supposed to be cleanup and not have any actual effects. Long term we should probably refactor EditPage and make the edit conflict handling pluggable or something, so it doesn't require overriding the whole page (composition not inheritance).

Change 377308 had a related patch set uploaded (by Addshore; owner: Addshore):
[mediawiki/extensions/TwoColConflict@master] Revert "Don't mess around with $wgHooks by using CustomEditor hook"

https://gerrit.wikimedia.org/r/377308

Addshore moved this task from Back Burner 🏛️ to Active 🚁 on the User-Addshore board.

Change 377308 merged by jenkins-bot:
[mediawiki/extensions/TwoColConflict@master] Revert "Don't mess around with $wgHooks by using CustomEditor hook"

https://gerrit.wikimedia.org/r/377308

Addshore closed this task as Resolved.Sep 15 2017, 2:38 PM

Looks like the issue is now fixed and will be deployed with the next train!

Addshore moved this task from Review to Done on the WMDE-QWERTY-Sprint-2017-09-05 board.