Page MenuHomePhabricator

Display custom message to user for query timeouts
Closed, ResolvedPublic

Description

Display a special message to the user if their query times out, rather than a raw exception.

This exception should still be manually logged to MWExceptionHandler->logException so we can track down the causes of the timeouts.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptSep 13 2017, 1:16 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 378687 had a related patch set uploaded (by Mattflaschen; owner: Mattflaschen):
[mediawiki/core@master] WIP: RCFilters: Display specific error if query times out.

https://gerrit.wikimedia.org/r/378687

@Mattflaschen-WMF, what is the wording of the message or messages? Are you, for example, indicating different causes for the timeout?

@Mattflaschen-WMF, what is the wording of the message or messages? Are you, for example, indicating different causes for the timeout?

Message is "This query took too long, so it could not be completed.", with no causes. Are causes easy to list?

@Mattflaschen-WMF, what is the wording of the message or messages? Are you, for example, indicating different causes for the timeout?

You can select a wording. There is only one message, since we don't know the precise cause (other than the query being slow).

You suggested mentioning that it might be due to a rare combination (not necessarily ORES-related) (that's not necessarily always true, but we could say 'perhaps' or something).

For wording, how about one of these? (It's nice to suggest a course of action, but only if it is actually liable to be helpful.)

  • This search has timed out. You may wish to try different search parameters.
  • This search has timed out. You may wish to try different search parameters or reduce the number of results requested.

Let's do the first one, since for some cases (e.g. T171027), even a small LIMIT will still scan millions of rows and timeout.

We could also discuss if we want a different message on watchlist (suggesting to reduce the number of items watched).

Change 378687 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Display specific error if query times out

https://gerrit.wikimedia.org/r/378687

Checked in enwiki (wmwf.6) - the timeout queries will display the message: This search has timed out. You may wish to try different search parameters.

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.Nov 8 2017, 4:47 PM