CodeMirror doesn't let you edit summary field
Closed, InvalidPublic

Description

From https://www.mediawiki.org/wiki/Topic:Tzrff9mbcw3gecw3 -

Using Firefox on MediaWiki versions 1.28 while CodeMIrror is enabled typing in the Summary text box does not work. The focus just keeps changing back to the main editing textbox field. If I disable CodeMirror using the button on the toolbar above the text field I can then edit the Summary textbox.That's a work around though. Would it be possible to create a bug to fix this issue? Thank you

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 11 2017, 10:35 PM

This just got more sinister -

Using Firefox on English Wikipedia, I am able to type in the Edit summary box with CodeMirror enabled, but when I click on one of the character insert buttons (provided by the CharInsert gadget, IIRC), as I do with most of my edit summaries to get the "→" character (as in: "somethng" → "something"), it always inserts into the article edit box even when when focus is in the Edit summary box

Also seems somewhat related to T164905: function mw.toolbar.insertTags does not work with CodeMirror in Chrome and IE.

Haven't been able to reproduce. Pinged the reporter on the thread.

This just got more sinister -

Using Firefox on English Wikipedia, I am able to type in the Edit summary box with CodeMirror enabled, but when I click on one of the character insert buttons (provided by the CharInsert gadget, IIRC), as I do with most of my edit summaries to get the "→" character (as in: "somethng" → "something"), it always inserts into the article edit box even when when focus is in the Edit summary box

Also seems somewhat related to T164905: function mw.toolbar.insertTags does not work with CodeMirror in Chrome and IE.

I can confirm this. When editing cs-wikipedia in Firefox + OWE with CodeMirror enabled, this happens to me. The → character is a shiny example, but it happens with other insertions as well - regardless of the pointer, they are always inserted into the article edit box (to the last edited place or to the beginning of the page). So as a workaround, I must use C+P to copy/move them back from the article edit field into the edit summary field (this works).

kaldari closed this task as Invalid.Nov 7 2017, 11:20 PM

So far, no one has been able to reproduce the bug described in the original report. The character insert bug (T179287) however seems to be legitimate.